VisualVM
  1. VisualVM
  2. VISUALVM-436

Temporarily unavailable remote servers are removed

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 1.3.1
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:

      PC,Linux

      Description

      VisualVM validates each defined remote JMX connection at start. Connections that cannot be reached or do not authenticate are removed from the remote host definition.

      This makes VisualVM cumbersome to use with more than a few remote servers, as

      • connection data to servers that are unavailable (even for a short period as a restart) at the moment of the application start is removed and needs to be re-entered
      • for each authenticated connection, the credentials need to be entered or saved by VisualVM, even though VisualVM might have been started just to connect to one specific server and all others are not of interest at that moment
      • startup of VisualVM is slowed down

      Bugfix:

      • don't remove JMX connection definitions automatically when a connection is not made
        Further enhancement ideas:
      • optionally provide a means to search and delete unavailable connections on user request
      • make connection validation optional

        Issue Links

          Activity

          rainerfrey added a comment -

          Actually, this is a duplicate of VISUALVM-415


            People

            • Assignee:
              Unassigned
              Reporter:
              rainerfrey
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: