Issue Details (XML | Word | Printable)

Key: VISUALVM-444
Type: Bug Bug
Status: Open Open
Priority: Major Major
Assignee: Unassigned
Reporter: geto
Votes: 2
Watchers: 3
Operations

If you were logged in you would be able to see more operations.
VisualVM

Remote-Host (see Environment) : VisualVM can't connect to jstatd

Created: 18/Apr/11 07:02 AM   Updated: 02/Dec/11 11:11 AM
Component/s: code
Affects Version/s: 1.3.2
Fix Version/s: None

Time Tracking:
Not Specified

Environment:

VisualVM: Windows XP, SP3
Remote-Host: Ubuntu Server 10.04 (Lucid Lynx) 64 Bit with OpenJDK 1.6.20 64 Bit


Tags: ubuntu 64 jstatd
Participants: brnfd, ferdez, geto, hesog and thurka


 Description  « Hide

Connect succesful with:

  • Ubuntu-Server 9.10-Karmic-Koala and Java 32-Bit-Sun 1.6.0_24

Not working:

  • Ubuntu Server 10.04 (Lucid Lynx) 64 Bit with OpenJDK 1.6.0_20 64 Bit
  • jstatd starts without error message:

    sudo jstatd -p 1234 -J-Djava.security.policy=all.policy -J-Djava.rmi.server.logCalls=true

  • jstatd receives VisualVM 1.32 -messages:

    sun.rmi.server.UnicastServerRef logCall
    FEINER: RMI TCP Connection(3)-10.xxx.yy.zzz: [10.xxx.yy.zzz: sun.rmi.registry.RegistryImpl[0:0:0, 0]: java.rmi.Remote lookup(java.lang.String)]}}

  • Log VisualVM is empty
  • telnet from Windows to jstatd-port okay


ferdez added a comment - 01/Jun/11 11:00 AM

Same problem here.

Client: VisualVM 1.3.2 on Windows 7/64, with Java 1.6.0_23/64bit
Server: Java 1.6.0_24 on linux 2.6.32 /Ubuntu 10.04 LTS 64bit)

VisualVM has no problems connecting with jstatd (log confirms) but the tomcat server running on that machine is not listed.


thurka added a comment - 09/Jun/11 03:56 AM

To ferdez:
Your problem is different. It is caused by a bug in JDK. See http://bit.ly/iaQmYP. The fix of this regression will be available in JDK 6 update 25.


hesog added a comment - 10/Jun/11 03:48 AM

I'm having a similar problem

VisualVM connects to remote server.
but i can't see any of the remote applications

the remote server is:

Distributor ID:	Ubuntu
Description:	Ubuntu 10.04.2 LTS
Release:	10.04
Codename:	lucid

java version "1.6.0_24"
Java(TM) SE Runtime Environment (build 1.6.0_24-b07)
Java HotSpot(TM) 64-Bit Server VM (build 19.1-b02, mixed mode)

to start the jstatd daemon i used this command:

$  jstatd -J-Djava.security.policy=jstatd.all.policy  -J-Djava.net.preferIPv4Stack=true

the client is VisualVM 1.6.0_24 running on UBUNTU 11.04 64bit


brnfd added a comment - 02/Dec/11 11:11 AM

Same problem to me:

When a I run VisualVM, jstatd keep loging:

Dec 02, 2011 8:47:11 AM sun.rmi.server.UnicastServerRef logCall
FINER: RMI TCP Connection(3)-192.xxx.yyy.zzz: [192.xxx.yyy.zzz: sun.rmi.registry.RegistryImpl[0:0:0, 0]: java.rmi.Remote lookup(java.lang.String)]
but never connect.

Jstatd is runnig on CentOS 5.7, 32-bits and JDK 1.7.0_01.
VisualVM version is 1.3.3, running on windows with JDK 1.7.0_01.

Running jstat locally via rmi works, but remote doesn't:
jstat -printcompilation rmi://pid@localhost:1099