VisualVM
  1. VisualVM
  2. VISUALVM-479

MBean plugin missing attribute values

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: plugins
    • Labels:
      None
    • Environment:

      Fedora 15, 2.6.41.1-1.fc15.i686, jre/jdk 1.6.0_29, Gnome 3.0.1-2, Tomcat 6.0.32

      Description

      Browsing MBean attributes made available by Apache Tomcat 6.0.32 generates different information when comparing visualvm 1.3.3 with jconsole. In particular, the following MBeans shows no attributes in visualvm, but all the attributes in jconsole.

      class name: org.apache.tomcat.util.modeler.BaseModelMBean
      ObjectName: Catalina:type=Engine

      See the attached screen shots.

      This occurs regardless of connection type (jstatd or localhost:9004 - the configured JMX port).

      1. jconsole-tc.png
        76 kB
      2. VisualVMscr.png
        41 kB
      3. visualvm-tc.png
        101 kB

        Activity

        thurka added a comment -

        I am sorry, I am unable to reproduce it. See attached screenshot.


          People

          • Assignee:
            thurka
            Reporter:
            mdeggersjava
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: