Details

    • Type: Sub-task Sub-task
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.3.5
    • Component/s: None
    • Labels:
      None
    • Environment:

      Windows 7 x64

      Description

      The name of Eclipse applications is shown as "null" instead of a valid name like "Eclipse" for Eclipse processes.

        Activity

        thurka added a comment -

        Can you please provide steps how to reproduce it? Which Eclipse application has "null" name?

        bebbo added a comment - - edited

        To reproduce:

        1. Start Eclipse
        2. Start VisualVM

        or

        1. Start VisualVM
        2. Start Eclipse

        eclipse.ini
        -vm
        c:/Program Files/Java/jdk1.7.0_05/bin/javaw.exe
        -startup
        plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
        --launcher.library
        plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.100.v20110502
        -showsplash
        org.eclipse.platform
        --launcher.XXMaxPermSize
        256m
        --launcher.defaultAction
        openFile
        -showsplash
        org.eclipse.platform
        --launcher.XXMaxPermSize
        256m
        --launcher.defaultAction
        openFile
        -vmargs
        -Xms40m
        -Xmx2048m
        

        Sometimes Eclipse also stops working if VisualVM is started.

        thurka added a comment -

        This works for me. Which version of Eclipse do you use? Are you able to monitor Eclipse if it has "null" name? Can you send me Application snapshot of Eclipse application and snapshot of VisualVM itself?

        bebbo added a comment -

        This happens with

        • Version: 3.7.1, Build id: M20110909-1335, Windows 64 Bit
        • Version: 4.2.0, Build id: I20120127-1145, Windows 64 Bit
        bebbo added a comment -

        Also happens with

        • Version: 3.7.2, Build id: M20120208-0800
        thurka added a comment -

        The problem seems to be caused by running Java VisualVM on 32bit JDK (C:\Program Files (x86)\Java\jdk1.7.0_05) while Eclipse is running on 64bit JDK (C:\Program Files\Java\jre7). Please run VisualVM on 64bit JDK or vice versa.

        thurka added a comment -

        FIxed in revision 3078.


          People

          • Assignee:
            thurka
            Reporter:
            bebbo
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: