VisualVM
  1. VisualVM
  2. VISUALVM-515

Memory Sampling Not available from Mac OS client to Linux server

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Works as designed
    • Affects Version/s: 1.3.4
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:

      Description

      I've written a custom javaagent with a premain hook as outlined here: https://blogs.oracle.com/jmxetc/entry/jmx_connecting_through_firewalls_using

      Instead of using RMI I am starting a JMXMP connector as outlined in this post: http://blog.markfeeney.com/2010/10/jmx-through-ssh-tunnel.html

      It's all working except that the Sample Memory button is disabled.
      It says "Memory Sampling Not available. Cannot connect to target application. Make sure the application is running on a supported JDK 6 or JDK 7."

      When running through the same JMXMP agent from an OS X client to a Java process on OS X it all works as expected.

        Activity

        frankgrimes97 added a comment -

        Note that I also tried with 1.7.0_07 and it's also exhibiting the same problem.

        OS X 10.8.2 client:

        java version "1.7.0_07"
        Java(TM) SE Runtime Environment (build 1.7.0_07-b10)
        Java HotSpot(TM) 64-Bit Server VM (build 23.3-b01, mixed mode)

        Gentoo server:

        java version "1.7.0_07"
        Java(TM) SE Runtime Environment (build 1.7.0_07-b10)
        Java HotSpot(TM) 64-Bit Server VM (build 23.3-b01, mixed mode)

        jsedlacek added a comment -

        Actually this works as designed - memory sampling is only available for locally running processes. Because of the tunneling VisualVM thinks it's a local process, otherwise it would display "Not available. Remote applications are not supported." But still you're monitoring a remote process for which the memory sampling isn't supported.


          People

          • Assignee:
            Unassigned
            Reporter:
            frankgrimes97
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: