wadl
  1. wadl
  2. WADL-1

wadl2java yahoo sample does not work with JAX-WS from GlassFish v2.

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: current
    • Fix Version/s: milestone 1
    • Component/s: www
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      1

      Description

      wadl2java yahoo sample does not work with JAX-WS from GlassFish v2.
      run:
      [java] Exception in thread "main" javax.xml.ws.WebServiceException: Illegal
      endpoint address:
      http://api.search.yahoo.com/NewsSearchService/V1/newsSearch?start=1&query=java
      sun&output=xml&sort=date&type=all&language=en&appid=jaxws_restful_sample&results=10
      [java] at
      com.sun.xml.ws.api.EndpointAddress.create(EndpointAddress.java:130)
      [java] at
      com.sun.xml.ws.client.RequestContext.setEndPointAddressString(RequestContext.java:140)
      [java] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      [java] at
      sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      [java] at
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      [java] at java.lang.reflect.Method.invoke(Method.java:585)
      [java] at
      com.sun.xml.ws.api.PropertySet$MethodAccessor.set(PropertySet.java:282)
      [java] at com.sun.xml.ws.api.PropertySet.put(PropertySet.java:342)
      [java] at com.sun.xml.ws.client.RequestContext.put(RequestContext.java:250)
      [java] at
      com.sun.xml.ws.client.dispatch.DispatchImpl.resolveEndpointAddress(DispatchImpl.java:288)
      [java] at
      com.sun.xml.ws.client.dispatch.DispatchImpl.doInvoke(DispatchImpl.java:165)
      [java] at
      com.sun.xml.ws.client.dispatch.DispatchImpl.invoke(DispatchImpl.java:193)
      [java] at
      com.sun.research.ws.wadl.util.JAXBDispatcher.doGET(JAXBDispatcher.java:92)
      [java] at
      com.yahoo.search.Endpoint$NewsSearch.getAsResultSet(Endpoint.java:197)
      [java] at com.sun.research.wadl2java.yahoo.Main.main(Main.java:40)
      [java] Caused by: java.net.URISyntaxException: Illegal character in query
      at index 78:
      http://api.search.yahoo.com/NewsSearchService/V1/newsSearch?start=1&query=java
      sun&output=xml&sort=date&type=all&language=en&appid=jaxws_restful_sample&results=10
      [java] at java.net.URI$Parser.fail(URI.java:2816)
      [java] at java.net.URI$Parser.checkChars(URI.java:2989)
      [java] at java.net.URI$Parser.parseHierarchical(URI.java:3079)
      [java] at java.net.URI$Parser.parse(URI.java:3021)
      [java] at java.net.URI.<init>(URI.java:578)
      [java] at
      com.sun.xml.ws.api.EndpointAddress.<init>(EndpointAddress.java:112)
      [java] at
      com.sun.xml.ws.api.EndpointAddress.create(EndpointAddress.java:128)
      [java] ... 14 more
      [java] Java Result: 1

        Activity

        mhadley added a comment -

        Bug verified, candidate fix checked into trunk, waiting for verification from issue originator.

        mhadley added a comment -

        Assigned to Marc

        mhadley added a comment -

        Fix available

        mhadley added a comment -

        Fix verified by mode.


          People

          • Assignee:
            mhadley
            Reporter:
            Rajiv Mordani
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: