Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: current
    • Fix Version/s: milestone 1
    • Component/s: www
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      2

      Description

      Despite media coverage, Vista actually made its way onto a real lot of
      machines, so it would be beneficial to support it.

      In fact, currently interop seems not to cover Vista (at least my Vista Business
      laptop fails at PUT, since it wants to create a lock even on non-lockable
      resources).

        Issue Links

          Activity

          mkarg added a comment -

          Created an attachment (id=3)
          Proposed solution to fake LOCK for Vista

          mkarg added a comment -

          (a) Vista does locking even if the resource says it does not support LOCK.

          A proposed solution is found in attachment "issue-2-proposed-vista-fake.patch":

          When the MiniRedir tries to do a LOCK, but the original resource returned "405"
          (NOT ALLOWED), which means that either the method is not implemented by the
          resource or the user has no right to obtain a lock, the Interop Filter jumps in
          and instead sends a slightly different "interpretation" of the response to the
          client, while not really sending a lie: The answer sent back is that the LOCK
          method was accepted (which is true, since the Interop Filter processed it), but
          the current lock is a shared one for any user and it has a timeout of zero
          seconds. That means, the semantics of the results are unchanged, but just the
          technical way to tell it to the client is changed. This is a very smart
          solution, and it is working on Vista Business.

          (b) Locking support has some bugs in both, webdav-jaxrs and webdav-addressbook.

          Just posted a question to the Jersey Mailing list, hoping to get some help. As
          this is not a showstopper to Vista, hereby Vista support is finished!

          daniel_manzke added a comment -

          WAIT FOR RELEASE 1.2 - Patch will be merged if ok

          daniel_manzke added a comment -
              • Issue 10 has been marked as a duplicate of this issue. ***
          daniel_manzke added a comment -

          The proposed solutions were patched into the trunk. Windows XP, 7, 2003, Vista and
          Office 2003 were tested with it.


            People

            • Assignee:
              mkarg
              Reporter:
              mkarg
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: