webdav-jaxrs
  1. webdav-jaxrs
  2. WEBDAV_JAXRS-1

Unmarshalled WebDAV body is (in part) null

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 1.2
    • Fix Version/s: 1.2
    • Component/s: www
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      1

      Description

      Some unmarshalled WebDAV body JAXB nodes (like the lock-info sent by a Vista's
      MiniRedirector) containing solely or in part NULL-pointers, while the actual
      XML sent by the client is correct.

        Activity

        mkarg added a comment -

        Fixed since 1.1.1

        The cause of this was incorrectly dealing with JAXB annotations and default
        behaviour:

        To ensure immutibility of the JAXB instances, most of them do not have setters
        by default. JAXB's default behaviour is to treat those properties is non-
        unmarshallable (read-only). Adding a @XmlElement / @XmlValue to the private
        field backing the property switches JAXB's behaviour from "property" mode
        to "field" mode. In "field" mode, the default behaviour is that the field is
        non-read-only. In turn, unmarshalling will occur.


          People

          • Assignee:
            webdav-jaxrs-issues
            Reporter:
            mkarg
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: