wsit
  1. wsit
  2. WSIT-1500

Missing WS-Addressing header: "{http://www.w3.org/2005/08/addressing}Action"

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.1
    • Fix Version/s: None
    • Component/s: transaction
    • Labels:
      None
    • Environment:

      Solaris Sparc, Glassfish v3 and Metro 2.1 latest bits

      Description

      All 3 tests in Sun 2 Sun Interop are failing.

      While running the tests I see " Missing WS-Addressing header: "

      {http://www.w3.org/2005/08/addressing}

      Action" in client side server log(domain1) and "javax.xml.ws.WebServiceException: com.sun.xml.ws.client.ClientTransportException: The server sent HTTP status code 404: Not Found
      " Exception in server side domain(domain2) log.

      Attaching the client side and server side applications, but this need some machine specific setup.Deploying these apps wont be successful.

      Please find the attached server log for both domains.

      The Invocation of the service is done using " Invoking URL: http://t24u-1.east.sun.com:8080/Transactional_Service_Sun_client/client?service=&alt_service=http://t24u-1:10080/Transactional_Service_Sun/TransactionalService&message=Rollback
      " where t24u-1.east.sun.com is the Host on which the service and client are deployed.

      1. server1.log
        54 kB
        Sreekanth
      2. server2.log
        62 kB
        Sreekanth

        Activity

        Sreekanth added a comment -

        Service and client war files used

        Marek Potociar added a comment -

        As it will be release-noted in Metro 2.1 release notes, the WS-TX endpoints are only deployed to the domain after a first WS endpoint gets deployed. Should one wants to use WS-TX services without any WS endpoint being deployed to the domain, one must deploy the wstx-services.war manually from the location

        <gf-home>/lib/install/applications/metro/

        e.g.:

        > cd $AS_HOME/bin
        > asadmin deploy ../lib/install/applications/metro/wstx-services.war

        Please verify if this workaround resolves the issue. Once resolved, we can waive the issue for this release.

        Marek Potociar added a comment -

        Since the suggested workaround is verified to work, downgrading the issue and waiving for Metro 2.1 release

        Marek Potociar added a comment -

        Reassigning to Paul - can you please check if the issue is still valid?

        paul_parkinson added a comment -

        Doced this requirement in rev 677:
        "
        The WS-C and WS-AT endpoints necessary for WS-AT are deployed when the first web service is deployed. Therefore, it is necessary to have at least one web service deployed for WS-AT to function properly even in the case where only clients are used in the Metro instance.
        "


          People

          • Assignee:
            paul_parkinson
            Reporter:
            Sreekanth
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: