Issue Details (XML | Word | Printable)

Key: WSIT-1502
Type: Bug Bug
Status: Resolved Resolved
Resolution: Fixed
Priority: Major Major
Assignee: Marek Potociar
Reporter: Sreekanth
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
wsit

javax.xml.ws.WebServiceException: Method registerOperation is exposed as WebMethod

Created: 03/Dec/10 06:56 AM   Updated: 03/Dec/10 07:45 AM   Resolved: 03/Dec/10 07:45 AM
Component/s: transaction
Affects Version/s: 2.1
Fix Version/s: 2.1

Time Tracking:
Not Specified

File Attachments: 1. File clean-domain.sh (2 kB) 03/Dec/10 06:56 AM - Sreekanth
2. Text File password.txt (0.1 kB) 03/Dec/10 06:56 AM - Sreekanth
3. Text File server1.log (150 kB) 03/Dec/10 07:11 AM - Sreekanth
4. File SimpleWebserviceApp.war (5 kB) 03/Dec/10 06:56 AM - Sreekanth

Environment:

Solaris,glassfish 3.1, metro 2.1 latest nightly bits


Tags:
Participants: Marek Potociar and Sreekanth


 Description  « Hide

While checking the fix for 1497, I uncovered this issue.

Steps for reproducing
=====================

1)Download the test bundle from here.
http://eas-v240-14.india.sun.com:8888/weld-custom-build/tango.zip

2)Make sure you have ant,java in your path
My environment variable settings look like:

export JAVA_HOME=/space/Sreekanth/java/jdk1.6.0_22
export AS_HOME=/space/Sreekanth/servers/glassfish3/glassfish
export ANT_HOME=/space/Sreekanth/ants/apache-ant-1.7.1
export PATH=$JAVA_HOME/bin:$AS_HOME/bin:$ANT_HOME/bin:$PATH

3). Setup GlassFish domains. Copy attached clean-domain.sh and password.txt to a local folder and run it. This creates 2 domains for the test.

4)Deploy simple webservice to domain1.
This is to overcome issue 1497.attaching a sample webservice to reproduce

5) Run the test.

$cd<local-dir>/tango/qe-tests/wstx/test
$ant -Dxtest.useGfV3=true -Dxtest.testtype=tx04 -Dxtest.sjsas.home=$AS_HOME -Dxtest.wsit.dest.dir=$AS_HOME/modules -Dxtest.http.port=8080 -Dxtest.useTomcat=false -Dwsit.lib=$AS_HOME/modules -Dxtest.metro.home=<location of unzipped metro.zip bundle>

6) Check $AS_HOME/domains/domain1/logs/server.log to see the exceptions.

Now you get the exception :
[#|2010-12-03T06:07:19.888+0530|SEVERE|glassfish3.1|javax.enterprise.system.core.security.com.sun.enterprise.security.webservices|_ThreadID=15;_ThreadName=Thread-1;|ws.error_next_pipe
javax.xml.ws.WebServiceException: javax.xml.ws.WebServiceException: Method registerOperation is exposed as WebMethod, but there is no corresponding wsdl operation with name Register in the wsdl:portType{http://docs.oasis-open.org/ws-tx/wscoor/2006/06}RegistrationCoordinatorPortType
at com.sun.xml.ws.tx.at.tube.WSATServerHelper.processIncomingTransaction(WSATServerHelper.java:138)
at com.sun.xml.ws.tx.at.tube.WSATServerHelper.doHandleRequest(WSATServerHelper.java:85)
at com.sun.xml.ws.tx.at.tube.WSATServerTube.processRequest(WSATServerTube.java:123)
at com.sun.xml.ws.api.pipe.Fiber.__doRun(Fiber.java:641)
at com.sun.xml.ws.api.pipe.Fiber._doRun(Fiber.java:600)
at com.sun.xml.ws.api.pipe.Fiber.doRun(Fiber.java:585)
at com.sun.xml.ws.api.pipe.Fiber.runSync(Fiber.java:482)
at com.sun.xml.ws.api.pipe.helper.AbstractTubeImpl.process(AbstractTubeImpl.java:116)
at com.sun.enterprise.security.webservices.CommonServerSecurityPipe.processRequest(CommonServerSecurityPipe.java:212)
at com.sun.enterprise.security.webservices.CommonServerSecurityPipe.process(CommonServerSecurityPipe.java:144)
at com.sun.xml.ws.api.pipe.helper.PipeAdapter.processRequest(PipeAdapter.java:119)
at com.sun.xml.ws.api.pipe.Fiber.__doRun(Fiber.java:641)
at com.sun.xml.ws.api.pipe.Fiber._doRun(Fiber.java:600)
at com.sun.xml.ws.api.pipe.Fiber.doRun(Fiber.java:585)
at com.sun.xml.ws.api.pipe.Fiber.runSync(Fiber.java:482)
at com.sun.xml.ws.server.WSEndpointImpl$2.process(WSEndpointImpl.java:314)
at com.sun.xml.ws.transport.http.HttpAdapter$HttpToolkit.handle(HttpAdapter.java:620)
at com.sun.xml.ws.transport.http.HttpAdapter.handle(HttpAdapter.java:271)
at com.sun.xml.ws.transport.http.servlet.ServletAdapter.handle(ServletAdapter.java:148)
at org.glassfish.webservices.Ejb3MessageDispatcher.handlePost(Ejb3MessageDispatcher.java:120)
at org.glassfish.webservices.Ejb3MessageDispatcher.invoke(Ejb3MessageDispatcher.java:91)
at org.glassfish.webservices.EjbWebServiceServlet.dispatchToEjbEndpoint(EjbWebServiceServlet.java:200)
at org.glassfish.webservices.EjbWebServiceServlet.service(EjbWebServiceServlet.java:131)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:848)
at com.sun.grizzly.http.servlet.ServletAdapter$FilterChainImpl.doFilter(ServletAdapter.java:1002)
at com.sun.grizzly.http.servlet.ServletAdapter$FilterChainImpl.invokeFilterChain(ServletAdapter.java:942)
at com.sun.grizzly.http.servlet.ServletAdapter.doService(ServletAdapter.java:404)
at com.sun.grizzly.http.servlet.ServletAdapter.service(ServletAdapter.java:354)
at com.sun.grizzly.tcp.http11.GrizzlyAdapter.service(GrizzlyAdapter.java:168)
at com.sun.enterprise.v3.server.HK2Dispatcher.dispath(HK2Dispatcher.java:117)
at com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:234)
at com.sun.grizzly.http.ProcessorTask.invokeAdapter(ProcessorTask.java:817)
at com.sun.grizzly.http.ProcessorTask.doProcess(ProcessorTask.java:718)
at com.sun.grizzly.http.ProcessorTask.process(ProcessorTask.java:1007)
at com.sun.grizzly.http.DefaultProtocolFilter.execute(DefaultProtocolFilter.java:225)
at com.sun.grizzly.DefaultProtocolChain.executeProtocolFilter(DefaultProtocolChain.java:137)
at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:104)
at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:90)
at com.sun.grizzly.http.HttpProtocolChain.execute(HttpProtocolChain.java:79)
at com.sun.grizzly.ProtocolChainContextTask.doCall(ProtocolChainContextTask.java:54)
at com.sun.grizzly.SelectionKeyContextTask.call(SelectionKeyContextTask.java:59)
at com.sun.grizzly.ContextTask.run(ContextTask.java:71)
at com.sun.grizzly.util.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:532)
at com.sun.grizzly.util.AbstractThreadPool$Worker.run(AbstractThreadPool.java:513)
at java.lang.Thread.run(Thread.java:662)
Caused by: javax.xml.ws.WebServiceException: Method registerOperation is exposed as WebMethod, but there is no corresponding wsdl operation with name Register in the wsdl:portType{http://docs.oasis-open.org/ws-tx/wscoor/2006/06}RegistrationCoordinatorPortType
at com.sun.xml.ws.model.JavaMethodImpl.freeze(JavaMethodImpl.java:356)
at com.sun.xml.ws.model.AbstractSEIModelImpl.freeze(AbstractSEIModelImpl.java:109)
at com.sun.xml.ws.model.RuntimeModeler.buildRuntimeModel(RuntimeModeler.java:256)
at com.sun.xml.ws.client.WSServiceDelegate.createSEIPortInfo(WSServiceDelegate.java:665)
at com.sun.xml.ws.client.WSServiceDelegate.addSEI(WSServiceDelegate.java:653)
at com.sun.xml.ws.client.WSServiceDelegate.getPort(WSServiceDelegate.java:347)
at com.sun.xml.ws.client.WSServiceDelegate.getPort(WSServiceDelegate.java:342)
at com.sun.xml.ws.client.WSServiceDelegate.getPort(WSServiceDelegate.java:334)
at javax.xml.ws.Service.getPort(Service.java:284)
at com.sun.xml.ws.tx.coord.v11.client.RegistrationServiceV11.getRegistrationCoordinatorPort(RegistrationServiceV11.java:108)
at com.sun.xml.ws.tx.coord.v11.client.RegistrationProxyBuilderImpl$RegistrationProxyImpl.<init>(RegistrationProxyBuilderImpl.java:83)
at com.sun.xml.ws.tx.coord.v11.client.RegistrationProxyBuilderImpl.build(RegistrationProxyBuilderImpl.java:65)
at com.sun.xml.ws.tx.at.tube.WSATServerHelper.register(WSATServerHelper.java:157)
at com.sun.xml.ws.tx.at.tube.WSATServerHelper.processIncomingTransaction(WSATServerHelper.java:130)
... 44 more

#]


Marek Potociar added a comment - 03/Dec/10 07:45 AM

Fixed operation name in the RegistrationCoordinatorPortType declaration (WSIT source repository rev 6630: http://java.net/projects/wsit/sources/svn/revision/6630 )

Please verify using the latest Metro build.