wsit
  1. wsit
  2. WSIT-1523

java.lang.IllegalStateException: Transaction null does not exist

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Invalid
    • Affects Version/s: 2.1
    • Fix Version/s: None
    • Component/s: transaction
    • Labels:
      None
    • Environment:

      glassfish 3.1

      Description

      This issue is in continuation to http://java.net/jira/browse/WSIT-1522

      Once we create a directory with name null on the place where we run appclient, now we see transactions are not flowed.

      Exception at server side:

      avax.enterprise.system.std.com.sun.enterprise.server.logging|_ThreadID=50;_ThreadName=Thread-1;|com.sun.xml.ws.tx.at.WSATException: java.lang.IllegalStateException: Transaction null does not exist, wsatResource=WSATXAResource: xidcom.sun.xml.ws.tx.at.internal.XidImpl@3132 status:ACTIVE epr:<?xml version="1.0" encoding="UTF-8" standalone="yes"?><EndpointReference xmlns="http://www.w3.org/2005/08/addressing"><Address>https://spidy:8181/__wstx-services/ParticipantPortType11</Address><ReferenceParameters><wsat-wsat:txId xmlns:ns2="http://docs.oasis-open.org/ws-tx/wscoor/2006/06" xmlns:wsa="http://www.w3.org/2005/08/addressing" xmlns:wsat-wsat="http://com.sun.xml.ws.tx.at/ws/2008/10/wsat">4D2-3444322D333133323339333533363330333733333332333333343332333632443330</wsat-wsat:txId><wsat-wsat:routing xmlns:ns2="http://docs.oasis-open.org/ws-tx/wscoor/2006/06" xmlns:wsa="http://www.w3.org/2005/08/addressing" xmlns:wsat-wsat="http://com.sun.xml.ws.tx.at/ws/2008/10/wsat">none</wsat-wsat:routing></ReferenceParameters><Metadata/></EndpointReference> isRemovedFromMap:false
      at com.sun.xml.ws.tx.at.internal.TransactionServicesImpl.enlistResource(TransactionServicesImpl.java:99)
      at com.sun.xml.ws.tx.coord.common.endpoint.BaseRegistration.enlistResource(BaseRegistration.java:161)
      at com.sun.xml.ws.tx.coord.common.endpoint.BaseRegistration.processRegisterTypeAndEnlist(BaseRegistration.java:112)
      at com.sun.xml.ws.tx.coord.common.endpoint.BaseRegistration.registerOperation(BaseRegistration.java:80)
      at com.sun.xml.ws.tx.coord.v11.endpoint.RegistrationPortImpl.registerOperation(RegistrationPortImpl.java:80)
      at sun.reflect.GeneratedMethodAccessor161.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.glassfish.webservices.InstanceResolverImpl$1.invoke(InstanceResolverImpl.java:143)
      at com.sun.xml.ws.server.InvokerTube$2.invoke(InvokerTube.java:150)
      at com.sun.xml.ws.server.sei.EndpointMethodHandler.invoke(EndpointMethodHandler.java:261)
      at com.sun.xml.ws.server.sei.SEIInvokerTube.processRequest(SEIInvokerTube.java:100)
      at com.sun.xml.ws.api.pipe.Fiber.__doRun(Fiber.java:641)
      at com.sun.xml.ws.api.pipe.Fiber._doRun(Fiber.java:600)
      at com.sun.xml.ws.api.pipe.Fiber.doRun(Fiber.java:585)
      at com.sun.xml.ws.api.pipe.Fiber.runSync(Fiber.java:482)
      at com.sun.xml.ws.api.pipe.helper.AbstractTubeImpl.process(AbstractTubeImpl.java:116)
      at org.glassfish.webservices.MonitoringPipe.process(MonitoringPipe.java:142)
      at com.sun.xml.ws.api.pipe.helper.PipeAdapter.processRequest(PipeAdapter.java:119)
      at com.sun.xml.ws.api.pipe.Fiber.__doRun(Fiber.java:641)
      at com.sun.xml.ws.api.pipe.Fiber._doRun(Fiber.java:600)
      at com.sun.xml.ws.api.pipe.Fiber.doRun(Fiber.java:585)
      at com.sun.xml.ws.api.pipe.Fiber.runSync(Fiber.java:482)
      at com.sun.xml.ws.api.pipe.helper.AbstractTubeImpl.process(AbstractTubeImpl.java:116)
      at com.sun.enterprise.security.webservices.CommonServerSecurityPipe.processRequest(CommonServerSecurityPipe.java:212)
      at com.sun.enterprise.security.webservices.CommonServerSecurityPipe.process(CommonServerSecurityPipe.java:144)
      at com.sun.xml.ws.api.pipe.helper.PipeAdapter.processRequest(PipeAdapter.java:119)
      at com.sun.xml.ws.api.pipe.Fiber.__doRun(Fiber.java:641)
      at com.sun.xml.ws.api.pipe.Fiber._doRun(Fiber.java:600)
      at com.sun.xml.ws.api.pipe.Fiber.doRun(Fiber.java:585)
      at com.sun.xml.ws.api.pipe.Fiber.runSync(Fiber.java:482)
      at com.sun.xml.ws.server.WSEndpointImpl$2.process(WSEndpointImpl.java:314)
      at com.sun.xml.ws.transport.http.HttpAdapter$HttpToolkit.handle(HttpAdapter.java:608)
      at com.sun.xml.ws.transport.http.HttpAdapter.handle(HttpAdapter.java:259)
      at com.sun.xml.ws.transport.http.servlet.ServletAdapter.handle(ServletAdapter.java:162)
      at org.glassfish.webservices.JAXWSServlet.doPost(JAXWSServlet.java:145)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:755)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:848)
      at org.apache.catalina.core.StandardWrapper.service(StandardWrapper.java:1534)
      at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:281)
      at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:175)
      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:655)
      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:595)
      at com.sun.enterprise.web.WebPipeline.invoke(WebPipeline.java:98)
      at com.sun.enterprise.web.PESessionLockingStandardPipeline.invoke(PESessionLockingStandardPipeline.java:91)
      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:162)
      at org.apache.catalina.connector.CoyoteAdapter.doService(CoyoteAdapter.java:326)
      at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:227)
      at com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:228)
      at com.sun.grizzly.http.ProcessorTask.invokeAdapter(ProcessorTask.java:818)
      at com.sun.grizzly.http.ProcessorTask.doProcess(ProcessorTask.java:719)
      at com.sun.grizzly.http.ProcessorTask.process(ProcessorTask.java:1008)
      at com.sun.grizzly.http.DefaultProtocolFilter.execute(DefaultProtocolFilter.java:225)
      at com.sun.grizzly.DefaultProtocolChain.executeProtocolFilter(DefaultProtocolChain.java:137)
      at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:104)
      at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:90)
      at com.sun.grizzly.http.HttpProtocolChain.execute(HttpProtocolChain.java:79)
      at com.sun.grizzly.ProtocolChainContextTask.doCall(ProtocolChainContextTask.java:54)
      at com.sun.grizzly.SelectionKeyContextTask.call(SelectionKeyContextTask.java:59)
      at com.sun.grizzly.ContextTask.run(ContextTask.java:71)
      at com.sun.grizzly.util.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:532)
      at com.sun.grizzly.util.AbstractThreadPool$Worker.run(AbstractThreadPool.java:513)
      at java.lang.Thread.run(Thread.java:662)
      Caused by: java.lang.IllegalStateException: Transaction null does not exist, wsatResource=WSATXAResource: xidcom.sun.xml.ws.tx.at.internal.XidImpl@3132 status:ACTIVE epr:<?xml version="1.0" encoding="UTF-8" standalone="yes"?><EndpointReference xmlns="http://www.w3.org/2005/08/addressing"><Address>https://spidy:8181/__wstx-services/ParticipantPortType11</Address><ReferenceParameters><wsat-wsat:txId xmlns:ns2="http://docs.oasis-open.org/ws-tx/wscoor/2006/06" xmlns:wsa="http://www.w3.org/2005/08/addressing" xmlns:wsat-wsat="http://com.sun.xml.ws.tx.at/ws/2008/10/wsat">4D2-3444322D333133323339333533363330333733333332333333343332333632443330</wsat-wsat:txId><wsat-wsat:routing xmlns:ns2="http://docs.oasis-open.org/ws-tx/wscoor/2006/06" xmlns:wsa="http://www.w3.org/2005/08/addressing" xmlns:wsat-wsat="http://com.sun.xml.ws.tx.at/ws/2008/10/wsat">none</wsat-wsat:routing></ReferenceParameters><Metadata/></EndpointReference> isRemovedFromMap:false
      at com.sun.xml.ws.tx.at.internal.WSATGatewayRM.registerWSATResource(WSATGatewayRM.java:234)
      at com.sun.xml.ws.tx.at.internal.TransactionServicesImpl.enlistResource(TransactionServicesImpl.java:97)
      ... 62 more

      #]
      1. b.out
        3 kB
        Sreekanth
      2. server.log
        19 kB
        Sreekanth

        Activity

        Sreekanth added a comment -

        Client side invocation output

        Sreekanth added a comment -

        Netbeans application for the same

        Sreekanth added a comment -

        Steps to reproduce:

        1)Unzip the attached netbeans application.
        2)In command line "cd" to the place where you extracted the application.
        3)Assuming the zip file is extraced to here:
        /home/sreekanth/NetBeansProjects/TxAppMandatory

        Now to build the tests do :
        bash:\> ant dist
        bash:\>asadmin deploy --retrieve dist --force=true dist/TxAppMandatory.ear
        bash:\>appclient -client dist/TxAppMandatoryClient.jar

        Make sure you have asadmin and ant in the Path.

        armanis added a comment -

        Problem persists after retesting against Glassfish 3.1.1 final, as expected I guess

        arjavdesai added a comment -

        AppClients are not supported with WS-AT as there is no JTA support in App client container. Only Web Client is supported.

        arjavdesai added a comment -

        We already have an enhancement request for the same WSIT-526


          People

          • Assignee:
            arjavdesai
            Reporter:
            Sreekanth
          • Votes:
            1 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: