wsit
  1. wsit
  2. WSIT-1550

JAX-RM tests are failing following a connection reset.

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: current
    • Fix Version/s: None
    • Component/s: rm
    • Labels:
      None
    • Environment:

      AIX 7.1, GF 3.1.1, Metro 2.1.1 , Java6 64 bit.

      Description

      When running the jax-rm functional test suite on AIX with GF3.1.1 & Metro 2.1.1 build in the middle of a particular test case the server connection is reset. All the subsequent tests fail. Not sure what is triggering the connection reset.

      From server log :

      [#|2011-05-10T08:41:25.199-0700|INFO|glassfish3.1|javax.enterprise.system.std.com.sun.enterprise.server.logging|_ThreadID=26;_ThreadName=Thread-6;|TEXT has been written to: /export/metro/hudson-test-workdir/workspace/tango/qe-tests/jax-rm/test/functional/destsecuresoaprtcprequestresponsecomplexPingComplexDrop1SessionRecord.log; with value of .... 5 [TEST ECHO] /export/metro/hudson-test-workdir/workspace/tango/qe-tests/jax-rm/test/functional/destsecuresoaprtcprequestresponsecomplexPingComplexDrop1SessionRecord.log;securesoaprtcprequestresponsecomplex:send complex echo|#]

      [#|2011-05-10T08:41:35.922-0700|WARNING|glassfish3.1|com.sun.metro.transport.tcp.server|_ThreadID=13;_ThreadName=Thread-6;|WSTCP0035: Channel-id Session: 382736080 Channel-id: 1 doesnt exist!|#]

      [#|2011-05-10T08:41:36.006-0700|WARNING|glassfish3.1|com.sun.metro.transport.tcp.server|_ThreadID=12;_ThreadName=Thread-6;|WSTCP1162: SOAP/TCP doesnt have own TCP listener, so the SOAP/TCP runtime is not able to set the valid port attribute. Port attribute is ignored|#]

      From client log :
      ner] May 10, 2011 8:41:36 AM com.sun.xml.ws.security.opt.impl.enc.CryptoProcessor encryptData
      [jvmTestRunner] FINEST: WSS1951: Encrypted Data is: <ns9:RequestSecurityToken xmlns:ns9="http://schemas.xmlsoap.org/ws/2005/02/trust"><ns9:TokenType>http://schemas.xmlsoap.org/ws/2005/02/sc/sct</ns9:TokenType><ns9:RequestType>http://schemas.xmlsoap.org/ws/2005/02/trust/Issue</ns9:RequestType><ns9:Entropy ns9:Type="BinarySecret"><ns9:BinarySecret Type="http://schemas.xmlsoap.org/ws/2005/02/trust/Nonce">ueIptinMWJRiXyhOdb/ZtQ==</ns9:BinarySecret></ns9:Entropy><ns9:KeySize>128</ns9:KeySize><ns9:KeyType>http://schemas.xmlsoap.org/ws/2005/02/trust/SymmetricKey</ns9:KeyType><ns9:ComputedKeyAlgorithm>http://schemas.xmlsoap.org/ws/2005/02/trust/CK/PSHA1</ns9:ComputedKeyAlgorithm></ns9:RequestSecurityToken>
      [jvmTestRunner] May 10, 2011 8:41:51 AM com.sun.xml.ws.transport.tcp.client.TCPTransportPipe process
      [jvmTestRunner] SEVERE: WSTCP0001:Processing message failed!
      [jvmTestRunner] Throwable occurred: com.sun.xml.ws.client.ClientTransportException: WSTCP0015:Error when exchanging protocol version
      [jvmTestRunner] at com.sun.xml.ws.transport.tcp.client.WSConnectionManager.createConnectionSession(WSConnectionManager.java:217)
      [jvmTestRunner] at com.sun.xml.ws.transport.tcp.util.WSTCPURI.createConnection(WSTCPURI.java:169)
      [jvmTestRunner] at com.sun.xml.ws.transport.tcp.util.WSTCPURI.createConnection(WSTCPURI.java:56)
      [jvmTestRunner] at com.sun.xml.ws.transport.tcp.connectioncache.impl.transport.OutboundConnectionCacheBlockingImpl.tryNewConnection(OutboundConnectionCacheBlockingImpl.java:239)
      [jvmTestRunner] at com.sun.xml.ws.transport.tcp.connectioncache.impl.transport.OutboundConnectionCacheBlockingImpl.get(OutboundConnectionCacheBlockingImpl.java:462)
      [jvmTestRunner] at com.sun.xml.ws.transport.tcp.client.WSConnectionManager.openChannel(WSConnectionManager.java:128)
      [jvmTestRunner] at com.sun.xml.ws.transport.tcp.client.TCPTransportPipe.setupClientTransport(TCPTransportPipe.java:248)
      [jvmTestRunner] at com.sun.xml.ws.transport.tcp.client.TCPTransportPipe.process(TCPTransportPipe.java:140)
      [jvmTestRunner] at com.sun.xml.ws.transport.tcp.client.TCPTransportPipe.processRequest(TCPTransportPipe.java:117)
      [jvmTestRunner] at com.sun.xml.ws.api.pipe.Fiber.__doRun(Fiber.java:641)
      [jvmTestRunner] at com.sun.xml.ws.api.pipe.Fiber._doRun(Fiber.java:600)
      [jvmTestRunner] at com.sun.xml.ws.api.pipe.Fiber.doRun(Fiber.java:585)
      [jvmTestRunner] at com.sun.xml.ws.api.pipe.Fiber.runSync(Fiber.java:482)
      [jvmTestRunner] at com.sun.xml.ws.security.secconv.WSSCPlugin.sendRequest(WSSCPlugin.java:404)
      [jvmTestRunner] at com.sun.xml.ws.security.secconv.WSSCPlugin.process(WSSCPlugin.java:263)
      [jvmTestRunner] at com.sun.xml.ws.security.secconv.impl.client.SCTokenProviderImpl.issue(SCTokenProviderImpl.java:135)
      [jvmTestRunner] at com.sun.xml.ws.api.security.trust.client.IssuedTokenManager.getIssuedToken(IssuedTokenManager.java:83)
      [jvmTestRunner] at com.sun.xml.wss.jaxws.impl.SecurityClientTube.startSecureConversation(SecurityClientTube.java:554)
      [jvmTestRunner] at com.sun.xml.ws.rx.util.Communicator.tryStartSecureConversation(Communicator.java:406)
      [jvmTestRunner] at com.sun.xml.ws.rx.rm.runtime.ClientTube.createSequences(ClientTube.java:409)
      [jvmTestRunner] at com.sun.xml.ws.rx.rm.runtime.ClientTube.openRmSession(ClientTube.java:347)
      [jvmTestRunner] at com.sun.xml.ws.rx.rm.runtime.ClientTube.processRequest(ClientTube.java:188)
      [jvmTestRunner] at com.sun.xml.ws.api.pipe.Fiber.__doRun(Fiber.java:641)
      [jvmTestRunner] at com.sun.xml.ws.api.pipe.Fiber._doRun(Fiber.java:600)
      [jvmTestRunner] at com.sun.xml.ws.api.pipe.Fiber.doRun(Fiber.java:585)
      [jvmTestRunner] at com.sun.xml.ws.api.pipe.Fiber.runSync(Fiber.java:482)
      [jvmTestRunner] at com.sun.xml.ws.client.Stub.process(Stub.java:323)
      [jvmTestRunner] at com.sun.xml.ws.client.sei.SEIStub.doProcess(SEIStub.java:161)
      [jvmTestRunner] at com.sun.xml.ws.client.sei.SyncMethodHandler.invoke(SyncMethodHandler.java:113)
      [jvmTestRunner] at com.sun.xml.ws.client.sei.SyncMethodHandler.invoke(SyncMethodHandler.java:93)
      [jvmTestRunner] at com.sun.xml.ws.client.sei.SEIStub.invoke(SEIStub.java:144)
      [jvmTestRunner] at $Proxy41.echoString(Unknown Source)
      [jvmTestRunner] at tango2tango.securesoaprtcprequestresponsecomplex.client.ReliableRequestresponseTest.sendEchoCore(ReliableRequestresponseTest.java:178)
      [jvmTestRunner] at tango2tango.securesoaprtcprequestresponsecomplex.client.ReliableRequestresponseTest.sendEcho(ReliableRequestresponseTest.java:277)
      [jvmTestRunner] at tango2tango.securesoaprtcprequestresponsecomplex.client.ReliableRequestresponseTest.testRqRepDroppedRqRep25(ReliableRequestresponseTest.java:123)
      [jvmTestRunner] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      [jvmTestRunner] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:60)
      [jvmTestRunner] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:37)
      [jvmTestRunner] at java.lang.reflect.Method.invoke(Method.java:611)
      [jvmTestRunner] at junit.framework.TestCase.runTest(TestCase.java:154)
      [jvmTestRunner] at org.netbeans.junit.NbTestCase.runBare(NbTestCase.java:136)
      [jvmTestRunner] at junit.framework.TestResult$1.protect(TestResult.java:106)
      [jvmTestRunner] at junit.framework.TestResult.runProtected(TestResult.java:124)
      [jvmTestRunner] at junit.framework.TestResult.run(TestResult.java:109)
      [jvmTestRunner] at junit.framework.TestCase.run(TestCase.java:118)
      [jvmTestRunner] at org.netbeans.junit.NbTestCase.run(NbTestCase.java:122)
      [jvmTestRunner] at junit.framework.TestSuite.runTest(TestSuite.java:208)
      [jvmTestRunner] at junit.framework.TestSuite.run(TestSuite.java:203)
      [jvmTestRunner] at org.netbeans.xtest.testrunner.JUnitTestRunner.runTests(JUnitTestRunner.java:167)
      [jvmTestRunner] at org.netbeans.xtest.testrunner.JUnitTestRunner.runTests(JUnitTestRunner.java:118)
      [jvmTestRunner] at org.netbeans.xtest.plugin.jvm.JUnitTestRunnerLauncher.main(JUnitTestRunnerLauncher.java:41)
      [jvmTestRunner] Caused by: java.net.ConnectException: A remote host refused an attempted connect operation.
      [jvmTestRunner] at sun.nio.ch.Net.connect(Native Method)
      [jvmTestRunner] at sun.nio.ch.SocketChannelImpl.connect(SocketChannelImpl.java:519)
      [jvmTestRunner] at sun.nio.ch.SocketAdaptor.connect(SocketAdaptor.java:93)
      [jvmTestRunner] at sun.nio.ch.SocketAdaptor.connect(SocketAdaptor.java:77)
      [jvmTestRunner] at com.sun.xml.ws.transport.tcp.io.Connection.create(Connection.java:249)
      [jvmTestRunner] at com.sun.xml.ws.transport.tcp.client.WSConnectionManager.createConnectionSession(WSConnectionManager.java:196)
      [jvmTestRunner] ... 50 more
      [jvmTestRunner] - test suite tango2tango.securesoaprtcprequestresponsecomplex.client.ReliableRequestresponseTest FAILED
      [jvmTestRunner] - time elapsed: 96.407 seconds
      [jvmTestRunner] - passed: 5 failed: 0 errors: 5 total: 10
      [jvmTestRunner] - success rate: 50.00%
      [jvmTestRunner]
      [jvmTestRunner] VM finished

      The logs are attached. Opening an issue track this. We will trying rerunning the whole test suite again.

        Issue Links

          Activity

          Sreekanth added a comment -

          With suggested fix for issue WSIT-1552, This issue is no longer observed.

          Marek Potociar added a comment -

          Once the issue WSIT-1552 is resolved, we should close this one.

          Marek Potociar added a comment -

          Assiging to the owner of WSIT-1552. Once the WSIT-1552 is resolved, this issue should be closed too.

          kumarjayanti added a comment -

          closing the issue since 1552 is resolved.


            People

            • Assignee:
              kumarjayanti
              Reporter:
              sonymanuel
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: