wsit
  1. wsit
  2. WSIT-1595

WARNING: MEX0008:Failed to parse metadata returned from server at

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.2
    • Fix Version/s: 2.2
    • Component/s: transaction
    • Labels:
      None
    • Environment:

      Linux,Glassfish3.1.2,Metro2.2

      Description

      Test Tx08 in WS-AT functional tests is failing.The issue is at the client side, while using wsimport, I see this output:

      wsimport-client-EJB:
      [wsimport] Consider using <depends>/<produces> so that wsimport won't do unnecessary compilation
      [wsimport] parsing WSDL...
      [wsimport]
      [wsimport]
      [xtest] 23 Nov, 2011 12:18:09 PM com.sun.xml.ws.mex.client.MetadataClient retrieveMetadata
      [xtest] WARNING: MEX0008:Failed to parse metadata returned from server at http://127.0.0.1:10080/sqe-wstx-tx08-service/EJB?wsdl using protocol SOAP_1_2. Continuing attempts.
      [xtest] 23 Nov, 2011 12:18:09 PM com.sun.xml.ws.mex.client.MetadataClient retrieveMetadata
      [xtest] WARNING: MEX0008:Failed to parse metadata returned from server at http://127.0.0.1:10080/sqe-wstx-tx08-service/EJB?wsdl using protocol SOAP_1_1. Continuing attempts.
      [xtest] 23 Nov, 2011 12:18:09 PM com.sun.xml.ws.mex.client.MetadataClient retrieveMetadata
      [xtest] WARNING: MEX0008:Failed to parse metadata returned from server at http://127.0.0.1:10080/sqe-wstx-tx08-service/EJB?wsdl/mex using protocol SOAP_1_2. Continuing attempts.
      [xtest] 23 Nov, 2011 12:18:09 PM com.sun.xml.ws.mex.client.MetadataClient retrieveMetadata
      [xtest] WARNING: MEX0008:Failed to parse metadata returned from server at http://127.0.0.1:10080/sqe-wstx-tx08-service/EJB?wsdl/mex using protocol SOAP_1_1. Continuing attempts.
      [wsimport] [ERROR] Server returned HTTP response code: 405 for URL: http://127.0.0.1:10080/sqe-wstx-tx08-service/EJB?wsdl
      [wsimport]
      [wsimport] Failed to read the WSDL document: http://127.0.0.1:10080/sqe-wstx-tx08-service/EJB?wsdl, because 1) could not find the document; /2) the document could not be read; 3) the root element of the document is not <wsdl:definitions>.
      [wsimport]
      [wsimport]
      [wsimport] [ERROR] failed.noservice=Could not find wsdl:service in the provided WSDL(s):
      [wsimport]
      [wsimport] At least one WSDL with at least one service definition needs to be provided.
      [wsimport]
      [wsimport]
      [wsimport] Failed to parse the WSDL.

        Activity

        Sreekanth added a comment - - edited

        When I try to view the wsdl using the url http://127.0.0.1:10080/sqe-wstx-tx08-service/EJB?wsdl,I get this :"Invalid wsdl request http://127.0.0.1:10080/sqe-wstx-tx08-service/EJB"

        This test passes in metro2.1.1/gf3.1.1

        It looks like this is similar to the issue http://java.net/jira/browse/GLASSFISH-14568

        Sreekanth added a comment -

        [Sun/Oracle internal]
        This hudson job can be used to reproduce the issue.
        http://ejp5355-vm2.india.sun.com:9999/view/Transactions/job/Transactions-Functional-V3.1.2-Metro2.2-tx08/

        Sreekanth added a comment -

        Steps to reproduce:
        ===================
        1)Download and install Glassfish 3.1.2 and metro2.2 latest nightly builds.
        2)Download the attached tango.zip bundle which contains the test case and unzip it
        3)Create a password.txt file with the below content(3 lines):
        AS_ADMIN_PASSWORD=adminadmin
        AS_ADMIN_USERPASSWORD=changeit
        AS_ADMIN_MASTERPASSWORD=changeit
        4)Also download the attached clean-domains.sh which will setup the environment
        5)Run the clean-domains.sh script
        6)Now move to the downloaded test bundle and execute the below ant commands to run the test case.

        cd $<Your-local-dir>/tango/qe-tests/wstx/test
        ant realclean

        ant -Dxtest.useGfV3=true -Dxtest.testtype=tx08 -Dxtest.sjsas.home=$AS_HOME -Dxtest.wsit.dest.dir=$AS_HOME/modules -Dxtest.http.port=8080 -Dxtest.useTomcat=false -Dwsit.lib=$AS_HOME/modules -Dxtest.metro.home=$WORKSPACE/metro

        NOTE:
        -In the above command, $AS_HOME will be the glassfish install location
        -$WORKSPACE should refer to the location where metro bundle is unzipped.

        arjavdesai added a comment -

        Submitted revision 6914.


          People

          • Assignee:
            arjavdesai
            Reporter:
            Sreekanth
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: