wsit
  1. wsit
  2. WSIT-1605

javax.naming.CommunicationException: Communication exception for SerialContext

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Invalid
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: transaction
    • Labels:
      None
    • Environment:

      Glassfish 3.1.2 ,Linux

      Description

      Test case Tx04 from SQE functional tests is failing with the below exception:

      [#|2012-01-05T15:33:27.238+0530|SEVERE|glassfish3.1.2|javax.enterprise.system.std.com.sun.enterprise.server.logging|_ThreadID=20;_ThreadName=Thread-2;|javax.naming.CommunicationException: Communication exception for SerialContext[myEnv=

      {java.naming.factory.initial=com.sun.enterprise.naming.impl.SerialInitContextFactory, java.naming.factory.state=com.sun.corba.ee.impl.presentation.rmi.JNDIStateFactoryImpl, java.naming.factory.url.pkgs=com.sun.enterprise.naming} [Root exception is java.lang.RuntimeException: com.sun.appserv.connectors.internal.api.ConnectorRuntimeException: This pool is not bound in JNDI : txpool]
      at com.sun.enterprise.naming.impl.SerialContext.lookup(SerialContext.java:542)
      at com.sun.enterprise.naming.impl.SerialContext.lookup(SerialContext.java:455)
      at javax.naming.InitialContext.lookup(InitialContext.java:392)
      at javax.naming.InitialContext.lookup(InitialContext.java:392)
      at transaction.usertransaction.ejb.Util.getConnection(Util.java:146)
      at transaction.usertransaction.ejb.Util.query(Util.java:120)
      at transaction.usertransaction.client.TestClient.tx406(TestClient.java:249)
      at transaction.usertransaction.client.TestClient.interopTest1(TestClient.java:133)
      at transaction.usertransaction.client.TestClient.runTransactionInteropTests(TestClient.java:126)
      at transaction.usertransaction.web.ServletClient.doGet(ServletClient.java:47)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:668)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:770)
      at org.apache.catalina.core.StandardWrapper.service(StandardWrapper.java:1542)
      at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:281)
      at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:175)
      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:655)
      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:595)
      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:161)
      at org.apache.catalina.connector.CoyoteAdapter.doService(CoyoteAdapter.java:331)
      at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:231)
      at com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:232)
      at com.sun.grizzly.http.ProcessorTask.invokeAdapter(ProcessorTask.java:849)
      at com.sun.grizzly.http.ProcessorTask.doProcess(ProcessorTask.java:746)
      at com.sun.grizzly.http.ProcessorTask.process(ProcessorTask.java:1045)
      at com.sun.grizzly.http.DefaultProtocolFilter.execute(DefaultProtocolFilter.java:228)
      at com.sun.grizzly.DefaultProtocolChain.executeProtocolFilter(DefaultProtocolChain.java:137)
      at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:104)
      at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:90)
      at com.sun.grizzly.http.HttpProtocolChain.execute(HttpProtocolChain.java:79)
      at com.sun.grizzly.ProtocolChainContextTask.doCall(ProtocolChainContextTask.java:54)
      at com.sun.grizzly.SelectionKeyContextTask.call(SelectionKeyContextTask.java:59)
      at com.sun.grizzly.ContextTask.run(ContextTask.java:71)
      at com.sun.grizzly.util.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:532)
      at com.sun.grizzly.util.AbstractThreadPool$Worker.run(AbstractThreadPool.java:513)
      at java.lang.Thread.run(Thread.java:662)
      Caused by: java.lang.RuntimeException: com.sun.appserv.connectors.internal.api.ConnectorRuntimeException: This pool is not bound in JNDI : txpool
      at com.sun.enterprise.resource.naming.ConnectorObjectFactory.getObjectInstance(ConnectorObjectFactory.java:201)
      at javax.naming.spi.NamingManager.getObjectInstance(NamingManager.java:304)
      at com.sun.enterprise.naming.impl.SerialContext.getObjectInstance(SerialContext.java:556)
      at com.sun.enterprise.naming.impl.SerialContext.lookup(SerialContext.java:514)
      ... 34 more
      Caused by: com.sun.appserv.connectors.internal.api.ConnectorRuntimeException: This pool is not bound in JNDI : txpool
      at com.sun.enterprise.connectors.service.ConnectorConnectionPoolAdminServiceImpl.obtainManagedConnectionFactory(ConnectorConnectionPoolAdminServiceImpl.java:1087)
      at com.sun.enterprise.connectors.ConnectorRuntime.obtainManagedConnectionFactory(ConnectorRuntime.java:417)
      at com.sun.enterprise.resource.naming.ConnectorObjectFactory.getObjectInstance(ConnectorObjectFactory.java:129)
      ... 37 more
      Caused by: javax.naming.NamingException: Lookup failed for '__SYSTEM/pools/txpool' in SerialContext[myEnv={java.naming.factory.initial=com.sun.enterprise.naming.impl.SerialInitContextFactory, java.naming.factory.state=com.sun.corba.ee.impl.presentation.rmi.JNDIStateFactoryImpl, java.naming.factory.url.pkgs=com.sun.enterprise.naming}

      [Root exception is javax.naming.NameNotFoundException: txpool not found]
      at com.sun.enterprise.naming.impl.SerialContext.lookup(SerialContext.java:518)
      at com.sun.enterprise.naming.impl.SerialContext.lookup(SerialContext.java:455)
      at javax.naming.InitialContext.lookup(InitialContext.java:392)
      at javax.naming.InitialContext.lookup(InitialContext.java:392)
      at com.sun.appserv.connectors.internal.api.ResourceNamingService.lookup(ResourceNamingService.java:221)
      at com.sun.enterprise.connectors.service.ConnectorConnectionPoolAdminServiceImpl.getConnectorConnectionPool(ConnectorConnectionPoolAdminServiceImpl.java:870)
      at com.sun.enterprise.connectors.service.ConnectorConnectionPoolAdminServiceImpl.obtainManagedConnectionFactory(ConnectorConnectionPoolAdminServiceImpl.java:1003)
      ... 39 more
      Caused by: javax.naming.NameNotFoundException: txpool not found
      at com.sun.enterprise.naming.impl.TransientContext.doLookup(TransientContext.java:248)
      at com.sun.enterprise.naming.impl.TransientContext.lookup(TransientContext.java:215)
      at com.sun.enterprise.naming.impl.TransientContext.lookup(TransientContext.java:219)
      at com.sun.enterprise.naming.impl.TransientContext.lookup(TransientContext.java:219)
      at com.sun.enterprise.naming.impl.SerialContextProviderImpl.lookup(SerialContextProviderImpl.java:77)
      at com.sun.enterprise.naming.impl.LocalSerialContextProviderImpl.lookup(LocalSerialContextProviderImpl.java:119)
      at com.sun.enterprise.naming.impl.SerialContext.lookup(SerialContext.java:505)
      ... 45 more

      #]

      [#|2012-01-05T15:33:27.241+0530|SEVERE|glassfish3.1.2|javax.enterprise.system.std.com.sun.enterprise.server.logging|_ThreadID=20;_ThreadName=Thread-2;|java.lang.RuntimeException: javax.naming.CommunicationException: Communication exception for SerialContext[myEnv=

      {java.naming.factory.initial=com.sun.enterprise.naming.impl.SerialInitContextFactory, java.naming.factory.state=com.sun.corba.ee.impl.presentation.rmi.JNDIStateFactoryImpl, java.naming.factory.url.pkgs=com.sun.enterprise.naming} [Root exception is java.lang.RuntimeException: com.sun.appserv.connectors.internal.api.ConnectorRuntimeException: This pool is not bound in JNDI : txpool]
      at transaction.usertransaction.ejb.Util.query(Util.java:138)
      at transaction.usertransaction.client.TestClient.tx406(TestClient.java:249)
      at transaction.usertransaction.client.TestClient.interopTest1(TestClient.java:133)
      at transaction.usertransaction.client.TestClient.runTransactionInteropTests(TestClient.java:126)
      at transaction.usertransaction.web.ServletClient.doGet(ServletClient.java:47)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:668)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:770)
      at org.apache.catalina.core.StandardWrapper.service(StandardWrapper.java:1542)
      at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:281)
      at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:175)
      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:655)
      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:595)
      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:161)
      at org.apache.catalina.connector.CoyoteAdapter.doService(CoyoteAdapter.java:331)
      at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:231)
      at com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:232)
      at com.sun.grizzly.http.ProcessorTask.invokeAdapter(ProcessorTask.java:849)
      at com.sun.grizzly.http.ProcessorTask.doProcess(ProcessorTask.java:746)
      at com.sun.grizzly.http.ProcessorTask.process(ProcessorTask.java:1045)
      at com.sun.grizzly.http.DefaultProtocolFilter.execute(DefaultProtocolFilter.java:228)
      at com.sun.grizzly.DefaultProtocolChain.executeProtocolFilter(DefaultProtocolChain.java:137)
      at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:104)
      at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:90)
      at com.sun.grizzly.http.HttpProtocolChain.execute(HttpProtocolChain.java:79)
      at com.sun.grizzly.ProtocolChainContextTask.doCall(ProtocolChainContextTask.java:54)
      at com.sun.grizzly.SelectionKeyContextTask.call(SelectionKeyContextTask.java:59)
      at com.sun.grizzly.ContextTask.run(ContextTask.java:71)
      at com.sun.grizzly.util.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:532)
      at com.sun.grizzly.util.AbstractThreadPool$Worker.run(AbstractThreadPool.java:513)
      at java.lang.Thread.run(Thread.java:662)
      Caused by: javax.naming.CommunicationException: Communication exception for SerialContext[myEnv={java.naming.factory.initial=com.sun.enterprise.naming.impl.SerialInitContextFactory, java.naming.factory.state=com.sun.corba.ee.impl.presentation.rmi.JNDIStateFactoryImpl, java.naming.factory.url.pkgs=com.sun.enterprise.naming}

      [Root exception is java.lang.RuntimeException: com.sun.appserv.connectors.internal.api.ConnectorRuntimeException: This pool is not bound in JNDI : txpool]
      at com.sun.enterprise.naming.impl.SerialContext.lookup(SerialContext.java:542)
      at com.sun.enterprise.naming.impl.SerialContext.lookup(SerialContext.java:455)
      at javax.naming.InitialContext.lookup(InitialContext.java:392)
      at javax.naming.InitialContext.lookup(InitialContext.java:392)
      at transaction.usertransaction.ejb.Util.getConnection(Util.java:146)
      at transaction.usertransaction.ejb.Util.query(Util.java:120)
      ... 29 more
      Caused by: java.lang.RuntimeException: com.sun.appserv.connectors.internal.api.ConnectorRuntimeException: This pool is not bound in JNDI : txpool
      at com.sun.enterprise.resource.naming.ConnectorObjectFactory.getObjectInstance(ConnectorObjectFactory.java:201)
      at javax.naming.spi.NamingManager.getObjectInstance(NamingManager.java:304)
      at com.sun.enterprise.naming.impl.SerialContext.getObjectInstance(SerialContext.java:556)
      at com.sun.enterprise.naming.impl.SerialContext.lookup(SerialContext.java:514)
      ... 34 more
      Caused by: com.sun.appserv.connectors.internal.api.ConnectorRuntimeException: This pool is not bound in JNDI : txpool
      at com.sun.enterprise.connectors.service.ConnectorConnectionPoolAdminServiceImpl.obtainManagedConnectionFactory(ConnectorConnectionPoolAdminServiceImpl.java:1087)
      at com.sun.enterprise.connectors.ConnectorRuntime.obtainManagedConnectionFactory(ConnectorRuntime.java:417)
      at com.sun.enterprise.resource.naming.ConnectorObjectFactory.getObjectInstance(ConnectorObjectFactory.java:129)
      ... 37 more
      Caused by: javax.naming.NamingException: Lookup failed for '__SYSTEM/pools/txpool' in SerialContext[myEnv=

      {java.naming.factory.initial=com.sun.enterprise.naming.impl.SerialInitContextFactory, java.naming.factory.state=com.sun.corba.ee.impl.presentation.rmi.JNDIStateFactoryImpl, java.naming.factory.url.pkgs=com.sun.enterprise.naming}

      [Root exception is javax.naming.NameNotFoundException: txpool not found]
      at com.sun.enterprise.naming.impl.SerialContext.lookup(SerialContext.java:518)
      at com.sun.enterprise.naming.impl.SerialContext.lookup(SerialContext.java:455)
      at javax.naming.InitialContext.lookup(InitialContext.java:392)
      at javax.naming.InitialContext.lookup(InitialContext.java:392)
      at com.sun.appserv.connectors.internal.api.ResourceNamingService.lookup(ResourceNamingService.java:221)
      at com.sun.enterprise.connectors.service.ConnectorConnectionPoolAdminServiceImpl.getConnectorConnectionPool(ConnectorConnectionPoolAdminServiceImpl.java:870)
      at com.sun.enterprise.connectors.service.ConnectorConnectionPoolAdminServiceImpl.obtainManagedConnectionFactory(ConnectorConnectionPoolAdminServiceImpl.java:1003)
      ... 39 more
      Caused by: javax.naming.NameNotFoundException: txpool not found
      at com.sun.enterprise.naming.impl.TransientContext.doLookup(TransientContext.java:248)
      at com.sun.enterprise.naming.impl.TransientContext.lookup(TransientContext.java:215)
      at com.sun.enterprise.naming.impl.TransientContext.lookup(TransientContext.java:219)
      at com.sun.enterprise.naming.impl.TransientContext.lookup(TransientContext.java:219)
      at com.sun.enterprise.naming.impl.SerialContextProviderImpl.lookup(SerialContextProviderImpl.java:77)
      at com.sun.enterprise.naming.impl.LocalSerialContextProviderImpl.lookup(LocalSerialContextProviderImpl.java:119)
      at com.sun.enterprise.naming.impl.SerialContext.lookup(SerialContext.java:505)
      ... 45 more

      #]

        Activity

        Sreekanth added a comment -

        Steps for reproducing
        =====================

        1)Download the test bundle from here.
        http://eas-v240-14.india.sun.com:8888/weld-custom-build/tango.zip

        2)Make sure you have ant,java in your path
        My environment variable settings look like:

        export JAVA_HOME=/space/Sreekanth/java/jdk1.6.0_22
        export AS_HOME=/space/Sreekanth/servers/glassfish3/glassfish
        export ANT_HOME=/space/Sreekanth/ants/apache-ant-1.7.1
        export PATH=$JAVA_HOME/bin:$AS_HOME/bin:$ANT_HOME/bin:$PATH

        3). Setup GlassFish domains. Copy attached clean-domain.sh and password.txt to a local folder and run it. This creates 2 domains for the test.

        4)Deploy simple webservice to domain1.
        This is to overcome issue 1497.attaching a sample webservice to reproduce

        5) Run the test.

        $cd<local-dir>/tango/qe-tests/wstx/test
        $ant -Dxtest.useGfV3=true -Dxtest.testtype=tx04 -Dxtest.sjsas.home=$AS_HOME -Dxtest.wsit.dest.dir=$AS_HOME/modules -Dxtest.http.port=8080 -Dxtest.useTomcat=false -Dwsit.lib=$AS_HOME/modules -Dxtest.metro.home=<location of unzipped metro.zip bundle>

        Sreekanth added a comment -

        To run only failing test case, change tango/qe-tests/wstx/functional/test/transaction/usertransaction/client/TestClientTest.java and enable only test901 and test 904

        arjavdesai added a comment -

        Was this passing before? If so, when did it pass last time?

        I see "Caused by: javax.naming.NameNotFoundException: txpool not found" but I don't see jdbc/txpool defined anywhere is GFS domain.

        Can you please re-run by creating jdbc/txpool as its looked up by tx04 app in, /qe-tests/wstx/functional/services/tx04/src/java/transaction/usertransaction/ejb/Util.java as well as /qe-tests/wstx/functional/pe/transaction/usertransaction/descriptor/sun-ejb-jar.xml?

        If that doesn't work than Product/GFS had something similar in the past: http://java.net/jira/browse/GLASSFISH-11436. Please assign to JNDI team, if it still doesn't work.

        Sreekanth added a comment -

        I checked with glassfish 3.1.1 server.It worked.It started failing from Dec 22nd in Glassfish 3.1.2.

        arjavdesai added a comment -

        Test setup issue.


          People

          • Assignee:
            arjavdesai
            Reporter:
            Sreekanth
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: