wsit
  1. wsit
  2. WSIT-1670

webservices-osgi should not require IBM JDK classes

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.2.1-1
    • Fix Version/s: 2.3.1
    • Component/s: build, wsit-runtime
    • Labels:
      None

      Description

      When trying to run in Karaf, I noticed that the MANIFEST.MF is requiring com.ibm.security.util,com.ibm.security.x509 which are not standard classes available in all JDKs. These should be made optional.

        Activity

        Hide
        Martin Grebac added a comment -

        Fixed in trunk:
        commit -m "Fix of JAXWS-1117 - Optionally import IBM JDK classes." /Users/snajper/work/sources/wsit~svn/trunk/bundles/webservices-osgi/pom.xml
        Sending /Users/snajper/work/sources/wsit~svn/trunk/bundles/webservices-osgi/pom.xml
        Transmitting file data ...
        Committed revision 7706.
        Revision: 7706
        Author : snajper
        Date : Sep 6, 2013 5:24:02 PM
        Fix of JAXWS-1117 - Optionally import IBM JDK classes.

        Show
        Martin Grebac added a comment - Fixed in trunk: commit -m "Fix of JAXWS-1117 - Optionally import IBM JDK classes." /Users/snajper/work/sources/wsit~svn/trunk/bundles/webservices-osgi/pom.xml Sending /Users/snajper/work/sources/wsit~svn/trunk/bundles/webservices-osgi/pom.xml Transmitting file data ... Committed revision 7706. Revision: 7706 Author : snajper Date : Sep 6, 2013 5:24:02 PM Fix of JAXWS-1117 - Optionally import IBM JDK classes.

          People

          • Assignee:
            Martin Grebac
            Reporter:
            atrajano
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: