wsit
  1. wsit
  2. WSIT-477

WSDLModel.WSDLParser.parse method stopped work for mex wsdl

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Cannot Reproduce
    • Affects Version/s: current
    • Fix Version/s: 1.0
    • Component/s: jaxws-runtime
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      477

      Description

      The method is used by [PolicyConfigParser] class in WSIT project
      to parse config files.
      This used to work till Feb-28-2007
      (http://kohsuke.sfbay/hudson/job/wsit-unit-test/760/).
      I will attach the affected wsdl file.

      Please see appropriate wsit junit test:
      $ cvs -d :pserver:cvs.dev.java.net:/cvs co wsit
      $ cd wsit/wsit/rt
      $ ant test

      Notice: In runtime wsdl parser there is hardcoded to register addressing
      extensions, which actually throw an exception. But the extensions are not needed
      in this case.

        Activity

        japod added a comment -

        Created an attachment (id=315)
        test case wsdl file

        vivekp added a comment -

        I think its duplicate of jaxws#284.

        I think I fixed it in the morning:
        https://jax-ws.dev.java.net/issues/show_bug.cgi?id=284. See
        wsit-javanet-bleedingedge#1960 or latter this particular test is passing. You
        may like to run with the latest jax-ws ri hudson you will see this test passing.

        japod added a comment -

        You are right, it works for me if I use the latest
        jax-ws from hudson.

        Thank you a lot.

        vivekp added a comment -

        Verified by Jakub, its already fixed as part of jaxws#284.

        mmatula added a comment -

        This issue was fixed before we created 1.0 branch, so the fix is in 1.0 ->
        setting target milestone to say so.


          People

          • Assignee:
            vivekp
            Reporter:
            Jakub Podlesak
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: