xadisk
  1. xadisk
  2. XADISK-126

FileIOUtility's renameTo method will not exit for copy-delete workaround of rename.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 1.2.1
    • Fix Version/s: None
    • Component/s: filesystem
    • Labels:
      None

      Description

      Many Thanks to Eugen for reporting it in the discussion thread at https://groups.google.com/forum/#!msg/xadisk/9ItZ5ddNDDg/HgqgFeWjs7kJ.

      The renameTo method of class FileIOUtility uses a workaround of copy-delete when rename does not seem to work, but is missing a break statement in the end.

        Activity

        Nitin Verma added a comment -

        This turned out to be a duplicate of https://java.net/jira/browse/XADISK-123, where we have resolved the issue using a break statement.


          People

          • Assignee:
            Nitin Verma
            Reporter:
            Nitin Verma
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: