xadisk
  1. xadisk
  2. XADISK-163

XASystemNoMoreAvailableException: The XADisk instance has encoutered a critial issue and is no more available

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 1.2.2
    • Fix Version/s: current
    • Component/s: filesystem
    • Labels:
      None
    • Environment:

      windows 7, jdk 1.6, websphere 7

      Description

      if i send a jms message and i write a lot of number file in xatransaction on roolback i catch this stack error:

      [14/05/14 12.24.23:267 CEST] 00000026 XATransaction E J2CA0027E: Si è verificata un'eccezione nel richiamare rollback in un adattatore risorse XA dal DataSource xadiskcf, nell'ID transazione

      {XidImpl: formatId(57415344), gtrid_length(36), bqual_length(54), data(00000145fa42f07c0000000100000006715745520ac55af173a42fa2316d88b0ade83ce800000145fa42f07c0000000100000006715745520ac55af173a42fa2316d88b0ade83ce8000000010000000000000000000000000002)}

      : javax.transaction.xa.XAException
      at org.xadisk.filesystem.utilities.MiscUtils.createXAExceptionWithCause(MiscUtils.java:18)
      at org.xadisk.connector.XAResourceImpl.rollback(XAResourceImpl.java:117)
      at com.ibm.ejs.j2c.XATransactionWrapper.rollback(XATransactionWrapper.java:1303)
      at com.ibm.tx.jta.JTAXAResourceImpl.rollback(JTAXAResourceImpl.java:363)
      at com.ibm.tx.jta.RegisteredResources.deliverOutcome(RegisteredResources.java:1654)
      at com.ibm.tx.jta.RegisteredResources.distributeOutcome(RegisteredResources.java:1933)
      at com.ibm.tx.jta.RegisteredResources.distributeRollback(RegisteredResources.java:2586)
      at com.ibm.tx.jta.TransactionImpl.internalRollback(TransactionImpl.java:1952)
      at com.ibm.tx.jta.TransactionImpl.internalRollback(TransactionImpl.java:1915)
      at com.ibm.tx.jta.TransactionImpl.rollback(TransactionImpl.java:1317)
      .............
      Caused by: org.xadisk.filesystem.exceptions.XASystemNoMoreAvailableException: The XADisk instance has encoutered a critial issue and is no more available. Such a condition is very rare. If you think you have setup everything right for XADisk to work, please consider discussing in XADisk forums, or raising a bug with details
      at org.xadisk.filesystem.NativeXAFileSystem.notifySystemFailure(NativeXAFileSystem.java:528)
      at org.xadisk.filesystem.NativeSession.rollback(NativeSession.java:1068)
      at org.xadisk.connector.XAResourceImpl.rollback(XAResourceImpl.java:113)
      ... 23 more
      Caused by: java.io.EOFException
      at org.xadisk.filesystem.utilities.FileIOUtility.readFromChannel(FileIOUtility.java:171)
      at org.xadisk.filesystem.TransactionLogEntry.getNextTransactionLogEntry(TransactionLogEntry.java:475)
      at org.xadisk.filesystem.NativeSession.rollback(NativeSession.java:1021)

      for replicate use this code in MDB spring:
      XADiskConnection connection = xaDisk.getConnection();
      File folder = new File("d:
      temp");
      if(!folder.exists())
      connection.createFile(folder, true);
      for (int j = 0; j < 10000; j++) {
      File f = new File("d:\\temp
      " + j + ".txt");
      connection.createFile(f, false);
      XAFileOutputStream out = connection.createXAFileOutputStream(f, false);
      out.write((System.currentTimeMillis() + "").getBytes());
      out.close();
      }

        Activity

        Nitin Verma added a comment -

        Thanks for identifying and reporting the issue. I have checked-in the fix to trunk. Please refer to revision #566. To resolve the issue, you can patch your local version of the xadisk with these changes.


          People

          • Assignee:
            Nitin Verma
            Reporter:
            steroberti
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: