xadisk
  1. xadisk
  2. XADISK-82

Remove ra.xml from the JAR artifact

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.1
    • Fix Version/s: 1.1
    • Component/s: misc
    • Labels:
      None

      Description

      Currently, the XADisk JAR artifact deployed to Maven central via maven.java.net contains a META-INF/ra.xml. This causes problems when deploying the exploded RAR artifact to JBoss 5.1.0, since JBoss will try to parse the ra.xml in the JAR (contained in the RAR) and fail.

      The problem can be fixed by excluding the ra.xml from the JAR, where it should not be in the first place. A patch to the pom.xml that corrects this is attached.

        Activity

        Nitin Verma added a comment - - edited

        Hello,

        Thanks for identifying this issue.

        Due to the recent migration to the new maven repository, I had created a separate pom.xml for uploading to the repository (as there were a few additional requirements), and missed out the ra.xml in the jar.

        (One won't find this "extra" ra.xml in everything.zip at the project website though).

        Thanks,
        Nitin

        Nitin Verma added a comment -

        I have uploaded the modified artifacts to Staging Repository, but the repository doesn't seem to allow updation/deletion of released artifacts (in the Release Repository). I have written an email to Sonatype folks to seek for advices regarding updation/deletion in such cases.

        Simon Dierl added a comment -

        If Sonatype does not allow to change an already uploaded artifact (makes sense for build reproducibility), what about releasing a 1.1.1 with the ra.xml change only? This would only mean a minor change to the pom.xml-s of those affected.

        Nitin Verma added a comment -

        Hello, SDierl (I am sorry I don't know how should I call you)

        Thanks for your advice.

        I have received response from Sonatype, and they say its not feasible to update (even slightest) or delete the released artifacts and the only option is to create another release.

        On that line, I have (I got a bit late in updating this bug) created a new release as "v1.1" (earlier it was "1.1"). It is now available at:

        http://search.maven.org/#browse|-815524010

        Would you like to confirm if the .rar from the new release "v1.1" deploys all fine for you.

        Thanks,
        Nitin

        Nitin Verma added a comment -

        Verified that the rar in the new release "v1.1" (http://search.maven.org/#browse|-815524010) is deploying and working fine on JBoss 5.1.0.

        Simon Dierl added a comment -

        Works for me, too. Thanks for the prompt response!

        Nitin Verma added a comment -

        Many Thanks, Simon

        Cheers...
        Nitin


          People

          • Assignee:
            Nitin Verma
            Reporter:
            Simon Dierl
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: