[ABOUT-154] Forums page never shows green "Forum Contains New Posts" icon Created: 06/Sep/12  Updated: 10/Oct/12

Status: Open
Project: about
Component/s: None
Affects Version/s: None
Fix Version/s: None

Type: Bug Priority: Major
Reporter: sanjay_dasgupta Assignee: fnikola
Resolution: Unresolved Votes: 0
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified
Environment:

Google chrome on MS-Windows 7 Professional 64 bit



 Description   

The Forums main page (http://www.java.net/forum) never shows the green "Forum Contains New Posts" icon. All the icons down the first column of the table are always gray ("Forum Contains No New Posts").

The green icon are shown only when I am logged in. The green icons turn gray as soon as I log out.



 Comments   
Comment by fnikola [ 10/Oct/12 ]

The current design of these indicators is linked to each user. Therefore, each post that has not been seen by a logged on user is flagged as new (green) and after the user sees it it will be marked as not new (gray). When not logged in the site treats the user as anonymous and it cannot determine if the post has been seen by the user and displays gray icon.

Perhaps we could keep the existing logic for logged on users and update the logic for anonymous users so that any post within a predetermined amount of time (1 day?) will be flagged as new (green).

Generated at Thu Dec 08 18:37:55 UTC 2016 using JIRA 6.2.3#6260-sha1:63ef1d6dac3f4f4d7db4c1effd405ba38ccdc558.