[GLASSFISH-14347] (UC) I can't run updatetool, due to some PYTHON bug Created: 02/Nov/10  Updated: 02/Dec/11

Status: Open
Project: glassfish
Component/s: update_center
Affects Version/s: V3
Fix Version/s: 4.0

Type: Bug Priority: Minor
Reporter: Yegor Bugayenko Assignee: Snjezana Sevo-Zenzerovic
Resolution: Unresolved Votes: 1
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified
Environment:

Operating System: All
Platform: Macintosh


Issuezilla Id: 14,347

 Description   

This is what I'm getting:

/opt/local/share/java/glassfishv3/updatetool/bin$ sudo ./updatetool
Unable to block on application (GetProcessPID() returned 18446744073709551016)
'import site' failed; use -v for traceback
Traceback (most recent call last):
File "/opt/local/share/java/glassfishv3/updatetool/bin/../vendor-packages/updatetool/main.py", line
426, in ?
main(sys.argv[1:])
File "/opt/local/share/java/glassfishv3/updatetool/bin/../vendor-packages/updatetool/main.py", line
51, in main
from common.boot import uc_error, init_app_locale, check_ips
File "/opt/local/share/java/glassfishv3/updatetool/vendor-packages/updatetool/common/boot.py",
line 42, in ?
import gettext
ImportError: No module named gettext

Where is a problem and how can I solve it? Thanks.



 Comments   
Comment by Bobby Bissett [ 02/Nov/10 ]

Switching over to update subcategory. (Happens all the time.)

Comment by Snjezana Sevo-Zenzerovic [ 02/Nov/10 ]

Could you please provide exact platform you use and which GlassFish version is this?

Comment by Yegor Bugayenko [ 02/Nov/10 ]

It's MacOS Darwin 10.6, Glassfish 3.0. Maybe this information will be helpful:

$ sudo port list glassfish* and installed
glassfishv3 @3 java/glassfishv3

$ sudo port list python* and installed
python24 @2.4.6 lang/python24
python24 @2.4.6 lang/python24
python26 @2.6.6 lang/python26
python_select @0.3 sysutils/python_select
python_select @0.3 sysutils/python_select

Comment by Joe Di Pol [ 13/Dec/10 ]

FYI, I've run updatetool 2.3u2 on MacOS 10.6.5 without a problem and that's consistent with what we see in our repository access data (many hits from MacOS 10.6). The gettext module is definitely include in the python runtime bundled with Update Center. What happens if you do:

/opt/local/share/java/glassfishv3/pkg/python2.4-minimal/bin/python
Python 2.4.5 (#17, Aug 7 2009, 12:39:30)
[GCC 4.0.1 (Apple Computer, Inc. build 5370)] on darwin
Type "help", "copyright", "credits" or "license" for more information.
>>> import gettext

Comment by Snjezana Sevo-Zenzerovic [ 21/Dec/10 ]

Based on Joe's analysis this seems to be environment issue. Targeting for future release.

Generated at Mon May 25 06:08:39 UTC 2015 using JIRA 6.2.3#6260-sha1:63ef1d6dac3f4f4d7db4c1effd405ba38ccdc558.