[GLASSFISH-16146] Umbrella bug. Created a domain with master password. Several start commands failed. Created: 03/Mar/11  Updated: 17/Oct/12

Status: Open
Project: glassfish
Component/s: admin
Affects Version/s: None
Fix Version/s: future release

Type: Improvement Priority: Major
Reporter: easarina Assignee: Bhakti Mehta
Resolution: Unresolved Votes: 0
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified

Issue Links:
depends on GLASSFISH-16150 Created a domain with master password... Resolved
depends on GLASSFISH-16147 Domain was created with master passwo... Open
depends on GLASSFISH-16149 Created a domain with a master passwo... Open
Tags: ee7ri_cleanup_deferred


Build 43. Sparc machine.
1) Created a new domain with master password. I.e. was used such command:

asadmin --passwordfile ./password.txt --user admin create-domain --domaindir /opt/glassfish3/glassfish/domains --adminport 9999 --instanceport 4444 --savemasterpassword=true --usemasterpassword=true --savelogin=false --checkports=true --nopassword=false domain12

2) Started domain
3) Created a cluster: asadmin --passwordfile ./password.txt --port 9999 --host localhost --user admin create-cluster c1
Command create-cluster executed successfully.
4) Created a local instance: asadmin --passwordfile ./password.txt --port 9999 --host localhost --user admin create-local-instance --cluster c1 --node localhost-domain12 in9
Rendezvoused with DAS on localhost:9999.
Port Assignments for server instance in9:
Command create-local-instance executed successfully.

5) Started a local instance: asadmin --passwordfile ./password.txt --port 9999 --host localhost --user admin start-local-instance --node localhost-domain12 in9
Waiting for in9 to start .................................
Successfully started the instance: in9
instance Location: /opt/glassfish3/glassfish/nodes/localhost-domain12/in9
Log File: /opt/glassfish3/glassfish/nodes/localhost-domain12/in9/logs/server.log
Admin Port: 24851
Command start-local-instance executed successfully.
6) Stopped a local instance: asadmin --passwordfile ./password.txt --port 9999 --host localhost --user admin stop-local-instance --node localhost-domain12 in9
Waiting for the instance to stop ...
Command stop-local-instance executed successfully.

Then tried to execute start-instance, restart-instance, start-cluster, all these commands failed. This is an umbrella bug for start with master password issues. For domains without master password, all these commnds worked fine.

Comment by Nazrul [ 03/Mar/11 ]

Requesting Bhakti to investigate if these are real issues.

Comment by Byron Nevins [ 08/Mar/11 ]

Bhakti - take a look at 16150 comments from me.

Try replacing the relative path of the password file to an absolute path (in the asadmin commands). Should only take a couple minutes to try...

Comment by Nazrul [ 20/Apr/11 ]

We should look in this issue during 3.1.1

Comment by Nazrul [ 02/May/11 ]

GlassFish 3.1 is behaving as expected. We never send master password over the wire. If user sets a master password, then 3.1 offer the following options:

1) Use create-local-instance --savemasterpassword option to save the master password locally
2) Use change-master-password --savemasterpassword option to save the master password locally

Converting these 3 issues to Improvement to investigate if we can make life any easier without compromising security.

Comment by Tom Mueller [ 17/Oct/12 ]

Marking the fix version field as "future-release". This is based on an evaluation by John, Michael, and Tom WRT to the PRD for the Java EE 7 RI/SDK. This issues was deemed to not be a P1 for that release. If this is in error or there are other reasons why this RFE should be targeted for the Java EE 7 RI/SDK release, then change the fix version field back to an appropriate build.

Generated at Sun Apr 19 10:10:55 UTC 2015 using JIRA 6.2.3#6260-sha1:63ef1d6dac3f4f4d7db4c1effd405ba38ccdc558.