[GLASSFISH-16667] [RN]Invoking GF installer on AIX6.1 with JDK6 64 bit gives Warning Created: 17/May/11  Updated: 02/Dec/14  Resolved: 02/Dec/14

Status: Closed
Project: glassfish
Component/s: installation
Affects Version/s: 3.1.1_b05
Fix Version/s: None

Type: Bug Priority: Critical
Reporter: Alex Pineda Assignee: Romain Grécourt
Resolution: Won't Fix Votes: 0
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified
Environment:

IBM PPC with AIX 6.1 OS, JDK6 64bit, Glassfish build 5.


Tags: 3_1-next_release-note-added, 3_1-next_release-notes, 3_1_1-scrubbed, 3_1_2-exclude

 Description   

On this system, JAVA_HOME=/usr/java6_64 which points to the 64bit version of the IBM JDK. When the installer is invoked, the following warning is displayed on the screen.

Warning: Could not detect OS Architecture, falling back to os.arch [Architecture=ppc64]

It's pretty visible and could cause customer calls.



 Comments   
Comment by Alex Pineda [ 17/May/11 ]

The same Warning is displayed when execution "uninstall.sh".

Comment by scatari [ 18/May/11 ]

This would require an update to "OpenInstaller" framework that is very risky to attempt at this stage of the release. Marking it for 3_1-next, this warning is harmless, we could potentially document this in Release Notes.

Comment by scatari [ 05/Jul/11 ]

Adding to the 3.1.1 release note queue.

Comment by Rebecca Parks [ 07/Jul/11 ]

Added the following to the 3.1.1 Release Notes:

Invoking GF installer on AIX 6.1 with JDK6 64 bit gives Warning (16667)

Description

When the GlassFish Server installer is invoked on the AIX 6.1 platform with the 64-bit version of JDK 6, the following warning is displayed on the screen:

Warning: Could not detect OS Architecture, falling back to os.arch [Architecture=ppc64]

Workaround

None. This warning is harmless and can be ignored.

Comment by Paul Davies [ 27/Oct/11 ]

This issue really is an installation issue for which a workaround has been added to the Release Notes. To enable this issue to be tracked for possibly fixing in a future release, I have changed the subcomponent to installation.

Comment by scatari [ 27/Oct/11 ]

We should try to fix this in 3.1.2. I will work with Romain to fix OpenInstaller.

Generated at Mon May 25 08:10:33 UTC 2015 using JIRA 6.2.3#6260-sha1:63ef1d6dac3f4f4d7db4c1effd405ba38ccdc558.