[GLASSFISH-17173] Build Errors on Java SE 7 Created: 09/Aug/11  Updated: 12/Dec/12  Resolved: 12/Dec/12

Status: Resolved
Project: glassfish
Component/s: build_system
Affects Version/s: None
Fix Version/s: 4.0_b67_ms7

Type: Bug Priority: Critical
Reporter: Byron Nevins Assignee: Unassigned
Resolution: Fixed Votes: 0
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified

Tags: 3_1_x-exclude


Isn't it time to solve this? GF can not be built using Java SE7. I am constantly going back and forth between 6 and 7 because of this.

[INFO] ------------------------------------------------------------------------
[INFO] ------------------------------------------------------------------------
[INFO] Internal error in the plugin manager executing goal 'org.glassfish.hk2:hk2-maven-plugin:1.6.12:hk2-compile': Unable to load the mojo 'org.glassfish.hk2:hk2-maven-plugin:1.6.12:hk2-compile' in the plugin 'org.glassfish.hk2:hk2-maven-plugin'. A required class is missing: com/sun/mirror/apt/AnnotationProcessorFactory

Comment by scatari [ 07/Nov/11 ]

GlassFish 3.1.x will not be built with JDK 7 to support compatibility.

Comment by Joe Di Pol [ 12/Dec/12 ]

This has been fixed in the 4.0 trunk.

Generated at Sat Oct 22 08:23:29 UTC 2016 using JIRA 6.2.3#6260-sha1:63ef1d6dac3f4f4d7db4c1effd405ba38ccdc558.