[GLASSFISH-19181] Upgrade the GlassFish codebase to require use of Java 7 Created: 18/Oct/12  Updated: 10/Dec/12  Resolved: 10/Dec/12

Status: Resolved
Project: glassfish
Component/s: build_system
Affects Version/s: None
Fix Version/s: 4.0

Type: Improvement Priority: Major
Reporter: Nigel Deakin Assignee: Romain Gr├ęcourt
Resolution: Fixed Votes: 0
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified

Issue Links:
blocks MQ-169 Make Connection and other interfaces ... Closed
blocks MQ-191 Migrate the MQ 5.0 codebase to compil... Closed


GlassFish needs to be upgraded to allow the use of Java 7. In particular it must allow a version of MQ to be integrated which uses Java 7.

MQ-191 is dependent on this.

Comment by marina vatkina [ 18/Oct/12 ]

GLASSFISH-19133 also depends on JDK 7

Comment by Tom Mueller [ 18/Oct/12 ]

This is required for the Java EE 7 RI/SDK

Comment by Tom Mueller [ 18/Oct/12 ]

GlassFish already allows the use of Java SE 7, however, it builds with -source 1.6 and -target 1.6.

The purpose of this issue to start building the appserver part of glassfish with -source 1.7 and -target 1.7 and to require that GlassFish be run with Java SE 7 (currently only Java SE 6 is enforced at runtime).
So there is a build aspect to this and a runtime aspect.

Comment by Romain Gr├ęcourt [ 10/Dec/12 ]

See svn rev #57168

Generated at Mon Oct 24 06:16:02 UTC 2016 using JIRA 6.2.3#6260-sha1:63ef1d6dac3f4f4d7db4c1effd405ba38ccdc558.