[GLASSFISH-19709] The windows version installer doesn't detect the JVM, and failed to start the installer. Created: 21/Feb/13  Updated: 21/Mar/13  Resolved: 21/Mar/13

Status: Resolved
Project: glassfish
Component/s: installation
Affects Version/s: 4.0_b77
Fix Version/s: 4.0

Type: Bug Priority: Major
Reporter: Mohamed Taman Assignee: Snjezana Sevo-Zenzerovic
Resolution: Duplicate Votes: 0
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified

Windows 7 SP1
Java SE 6 u41
Java SE 7 u15

Tags: adoptajsr


1- I have downloaded Glassfish, windows version glassfish-4.0-b77-windows-ml.
2- I have 2 versions of JDK version 6_u41 and 7_u15.
3- Click the installer, it will popup a setup error message as the following:

"This application needs version 1.6 or higher of the Java(TM) 2 runtime Environment..... etc."

It should detect already existing JVM version, which installed normally.

Comment by Snjezana Sevo-Zenzerovic [ 21/Mar/13 ]

I will consolidate this issue with GLASSFISH-19877 which has the same root cause. Native install wrapper does have issues with reliable 64 bit JDK detection on Windows platforms.

Generated at Tue Oct 13 10:06:33 UTC 2015 using JIRA 6.2.3#6260-sha1:63ef1d6dac3f4f4d7db4c1effd405ba38ccdc558.