[GLASSFISH-20698] Update tools can't work with python error Created: 12/Jul/13  Updated: 12/Jul/13

Status: Open
Project: glassfish
Component/s: update_center
Affects Version/s: 4.0_b89_RC5
Fix Version/s: None

Type: Bug Priority: Major
Reporter: trukhinyuri Assignee: Snjezana Sevo-Zenzerovic
Resolution: Unresolved Votes: 0
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified
Environment:

cent os 6.4


Tags: updatetool

 Description   

Bug, when launch update tool from terminal:

WX import error. Verify the WX widgets are in the PYTHONPATH.
The following can be reported to GlassFish Update Tool 2.3.5 Development Team <dev@updatecenter.java.net>.

Traceback (innermost last):
File "/usr/share/glassfish4/updatetool/vendor-packages/updatetool/common/boot.py", line 283, in init_app_locale
import wx
File "wx/_init_.py", line 45, in ?
File "wx/_core.py", line 4, in ?
ImportError: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory



 Comments   
Comment by Snjezana Sevo-Zenzerovic [ 12/Jul/13 ]

Moving to correct subcategory. Need to track down system requirements since CentOS was not on certified Linux platform list and as such not covered by in-house testing.

Generated at Sun Aug 30 07:39:19 UTC 2015 using JIRA 6.2.3#6260-sha1:63ef1d6dac3f4f4d7db4c1effd405ba38ccdc558.