[GLASSFISH-3744] <BT6612851>After installation of LB on WS 7.0u1 , WS instance fails to start on windows Created: 05/Oct/07  Updated: 06/Mar/12

Status: Open
Project: glassfish
Component/s: load_balancer
Affects Version/s: 9.1peur1
Fix Version/s: not determined

Type: Bug Priority: Minor
Reporter: gfbugbridge Assignee: pj126383
Resolution: Unresolved Votes: 0
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified
Environment:

Operating System: All
Platform: All


Issuezilla Id: 3,744

 Description   

*********READ-ONLY Data from Bugtraq*********************
Inside SWAN :http://swsblweb1.central.sun.com:8080/CrPrint?id=6612851
Outside SWAN :http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6612851
**********READ-ONLY Data from Bugtraq Ends********
*********READ-ONLY Data from Bugtraq*********************
Description –
**********READ-ONLY Data from Bugtraq Ends********
*********READ-ONLY Data from Bugtraq*********************
Description Install WS 7.0 u1

{Make sure the instance starts up fine}

Install AS 9.1 ee build 58g - Choose to install the LB plugin
The server instance fails to start with an error message :

[03/Oct/2007:15:11:07] failure ( 1840): CORE2253: Error running Init function lo
ad-modules: dlopen of C:/smitha/ws7-new/plugins/lbplugin/bin/passthrough.dll fai
led (The specified module could not be found.)

**********READ-ONLY Data from Bugtraq Ends********
*********READ-ONLY Data from Bugtraq*********************
Justification Priority changed from [] to [3-Medium]Error message cannot be XXXXXX 2007-10-04 05:00:46 GMT

**********READ-ONLY Data from Bugtraq Ends********
*********READ-ONLY Data from Bugtraq*********************
Work Around Download the latest LB plugin from : cp /net/koori.sfbay/onestop/glassfish/external/<OS>/aslb/jars/aslb-9.1-MS4-<latest>.jar

Unjar it and unzip SUNWaspx.zip
Copy icudt2.dll, icuin2.dll, icuuc2.dll and xerces-c.dll from the lib directory.

Put the above 4 dll in the same directory as passthrough.dll in <webserver7_install_dir>\plugins\lbplugin\bin.

**********READ-ONLY Data from Bugtraq Ends********
*********READ-ONLY Data from Bugtraq*********************
Work Around The required dlls are available in the AS/lib but the AS/lib is not in the path and hence the the WS instance doesn't start up.The 2 ways to get it working are
a) have all the dependent dlls in the same location i.e copy icudt2.dll, icuin2.dll, icuuc2.dll and xerces-c.dll from AS lib directory to the <webserver7_install_dir>\plugins\lbplugin\bin
OR
b)set the AS/lib in the systems environment . This needs a system restart.

**********READ-ONLY Data from Bugtraq Ends********



 Comments   
Comment by sanandal [ 11/Jan/09 ]

"Reclassifying as P4 because this issue is not deemed "must fix" for this v2.1
release whose primary release driver is SailFin.
This issue will be scrubbed after this release and will be given the right
priority for the next release."

Comment by Tom Mueller [ 06/Mar/12 ]

Bulk update to change fix version to "not determined" for all issues still open but with a fix version for a released version.

Generated at Mon Feb 08 04:59:59 UTC 2016 using JIRA 6.2.3#6260-sha1:63ef1d6dac3f4f4d7db4c1effd405ba38ccdc558.