[GLASSFISH-6544] getStringForDDxml FileNotFoundException-admin console in cluster crashes Created: 15/Oct/08  Updated: 08/Mar/13  Resolved: 08/Mar/13

Status: Resolved
Project: glassfish
Component/s: admin_gui
Affects Version/s: 9.1peur2
Fix Version/s: None

Type: Bug Priority: Minor
Reporter: suneelgv Assignee: Anissa Lam
Resolution: Won't Fix Votes: 5
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified
Environment:

Operating System: All
Platform: All


Issuezilla Id: 6,544
Tags: 3_1_x-exclude

 Description   

1. Create a war containing a webservice using annotations.
2. Deploy it to glassfish.
3. Now go to admin console and try to navigate the webservice. You'll see a warning.
4. Now try deploying the same to a clustered enviroment.
5. Now try to navigate the admin console of the cluster.
6. The admin console crashes with a error.

For the logs and more inforamtion, ref to:
http://forums.java.net/jive/thread.jspa?threadID=49684&tstart=0

Thanks
Suneel



 Comments   
Comment by sanandal [ 11/Jan/09 ]

"Reclassifying as P4 because this issue is not deemed "must fix" for this v2.1
release whose primary release driver is SailFin.
This issue will be scrubbed after this release and will be given the right
priority for the next release."

Comment by estiedi [ 24/Jun/09 ]
      • Issue 6544 has been confirmed by votes. ***
Comment by vincewebb [ 04/Jan/10 ]

I am not deploying to a clustered environment but I am seeing the same error.

I have a JAX-WS web service created using NetBeans 6.5

The web service is deployed to Sun Java System Application Server 9.1_02 (build
b04-fcs) as a web application named "serviceForumWs".

The web service works but occasionally it logs the following:

WARNING|sun-appserver9.1|javax.enterprise.system.tools.admin|_ThreadID=17;_ThreadName=httpWorkerThread-4849-1;_RequestID=b9e420fd-358a-4c8e-9f0f-716d3f9e2e00;|com.sun.enterprise.admin.mbeans.J2EEModule:getStringForDDxml
FileNotFoundException
/opt/SUNWappserver/domains/domain1/generated/xml/j2ee-modules/serviceForumWs/null|#]

In most cases I am aware of no ill effects and service appears to be unaffected
however on some occasions it coincides with the app server playing dead. On
these occasions it tends to appear some time after the app server dies and it is
the only entry in server.log until the app server is shut down and re-started.

I hope this helps

Vince

Comment by Anissa Lam [ 08/Mar/13 ]

This is for previous release, v2, and cannot be reproduced on v3 and v4. Marking as will not fix.

Generated at Mon Mar 30 13:24:35 UTC 2015 using JIRA 6.2.3#6260-sha1:63ef1d6dac3f4f4d7db4c1effd405ba38ccdc558.