[GLASSFISHPLUGINS-363] Eclipse plugins for Juno are broken Created: 02/Mar/13  Updated: 13/Mar/13  Resolved: 13/Mar/13

Status: Resolved
Project: glassfishplugins
Component/s: eclipse
Affects Version/s: None
Fix Version/s: None

Type: Bug Priority: Major
Reporter: petino Assignee: Unassigned
Resolution: Fixed Votes: 3
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified
Environment:

Eclipse Juno (4.2), Glassfish Eclipse plugin 3.1.2.201302271422



 Description   

Attempt to install Glassfish plugins for Eclipse Juno fails because of failed dependencies:

Available software at http://download.java.net/glassfish/eclipse/juno lists only:

GlassFish 3.1.2.2 Application Server runtime 3.1.2.201302271422
GlassFish 4.0 Server runtime 4.0.0.201302271422

Checking and installing the 3.1.2.2 fails:

Cannot complete the install because one or more required items could not be found.
Software being installed: GlassFish 3.1.2.2 Application Server runtime 3.1.2.201302271422 (oracle.eclipse.runtime.juno.runtime.glassfish3122.feature.group 3.1.2.201302271422)
Missing requirement: GlassFish 3.1.2.2 Application Server Runtime 3.1.2.201302271422 (oracle.eclipse.runtime.glassfish3122 3.1.2.201302271422) requires 'bundle oracle.eclipse.tools.glassfish 5.0.1.20130225' but it could not be found
Cannot satisfy dependency:
From: GlassFish 3.1.2.2 Application Server runtime 3.1.2.201302271422 (oracle.eclipse.runtime.juno.runtime.glassfish3122.feature.group 3.1.2.201302271422)
To: oracle.eclipse.runtime.glassfish3122 [3.1.2.201302271422]



 Comments   
Comment by bumphrey [ 08/Mar/13 ]

There is a new build available ( from March 6th.) that allowed me to install the plugin into eclipse juno.

Comment by petino [ 09/Mar/13 ]

OK, but this time there is no eclipse repository at all. ../helios is there but no juno at this time.

Comment by petino [ 09/Mar/13 ]

BTW ../indigo is missing as well

Comment by petino [ 09/Mar/13 ]

I tried Eclipse Marketplace and there is Oracle tools for Eclipse at download.oracle.com/otn_software/oepe/juno/plugins but seems that has an old plugin version. And failed to install on my clean Eclipse 4.2 SR2 (Juno)

Comment by piotrik [ 13/Mar/13 ]

Hi guys, the update site was restored with the version that were there before it went down. Sorry for inconvenience, here is the explanation what was happening and what is going to happen soon - http://blogs.oracle.com/piotrik/entry/migration_of_eclipse_plugins_java

Generated at Sat Feb 13 23:54:42 UTC 2016 using JIRA 6.2.3#6260-sha1:63ef1d6dac3f4f4d7db4c1effd405ba38ccdc558.