[JAVAEETUTORIAL-162] Typo (Java SE instead of JAVA EE) Created: 23/May/13  Updated: 23/May/13  Resolved: 23/May/13

Status: Resolved
Project: javaeetutorial
Component/s: doc
Affects Version/s: 6.0.8
Fix Version/s: None

Type: Bug Priority: Trivial
Reporter: Michael Dobrovolsky Assignee: Ian Evans
Resolution: Invalid Votes: 0
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified


 Description   

Typo in Java Database Connectivity API section. Should be: The Java EE 6 platform requires JDBC 4.0. Instead of: The Java SE 6 platform requires JDBC 4.0.



 Comments   
Comment by Ian Evans [ 23/May/13 ]

"Java SE" is actually correct here. Starting with Java SE 1.4.2, JDBC is a required technology for Java Platform, Standard Edition. Java SE 6 requires JDBC 4.0, as described in Section 2 ("Component JSRs") of JSR 270, the specification for Java SE 6.
http://jcp.org/aboutJava/communityprocess/final/jsr270/index.html

Java EE 6 requires Java SE 6 or higher. JSR 316 is the specification for Java SE 6, and has this to say about JDBC in section EE.2.7.6:
"The JDBC API is included in Java SE, but this specification includes additional requirements on JDBC device drivers."

The JDBC API itself, though, is provided by Java SE. You could say that Java EE 6 indirectly requires JDBC 4.0 through its dependency on Java SE 6. I'll rewrite this sentence for the Java EE 7 Tutorial to make it more clear.

Generated at Thu Dec 08 08:32:38 UTC 2016 using JIRA 6.2.3#6260-sha1:63ef1d6dac3f4f4d7db4c1effd405ba38ccdc558.