[JAVAMONEY-69] isLowerBound and isUpperBound should be hasLowerBound and hasUpperBound in ProviderContext Created: 09/Mar/14  Updated: 05/Feb/15  Resolved: 10/Mar/14

Status: Closed
Project: javamoney
Component/s: API
Affects Version/s: 0.7
Fix Version/s: 0.8

Type: Bug Priority: Major
Reporter: keilw Assignee: atsticks
Resolution: Fixed Votes: 0
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified

Tags: conversion

 Description   

The ProviderContext class in the "convert" package has 2 methods isLowerBound() and isUpperBound().
While is* tends to be used for boolean getters, there are exceptions, and those cases prefer has*

API elements with a similar purpose like *Range in Google Guava consistently call these
public boolean hasLowerBound() or hasUpperBound().


Generated at Tue Mar 28 18:37:27 UTC 2017 using JIRA 6.2.3#6260-sha1:63ef1d6dac3f4f4d7db4c1effd405ba38ccdc558.