[JDIC-544] Fail to open Thunderbird with attachments Created: 23/Sep/10  Updated: 03/Nov/11

Status: Open
Project: jdic
Component/s: JDIC API (package org.jdesktop.jdic.desktop)
Affects Version/s: 0.9
Fix Version/s: None

Type: Bug Priority: Major
Reporter: hubere Assignee: michael_shan
Resolution: Unresolved Votes: 0
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified
Environment:

Operating System: All
Platform: All


Attachments: File thunderbird.diff    
Issuezilla Id: 544

 Description   

I tried to send an email with attachemts through Thunderbird (3.1.4) and got an
error message.
The reason for this error message is the command line constructed by
WinMozMailer in WinMozMailer#constructArgs(...) method. It appears that there
will be a dangling comma at the end of the attachment string causing Thunderbird
to fail.
A command line constructed by WinMozMailer might look like this:
"C:\Programme\Mozilla Thunderbird\thunderbird.exe" -compose
"to='Edi@de,',attachment='file://d:/cadis/MyMobiler.zip,'"
(mind the comma at the end!)

Thunderbird does not like this line but rather wants on without the comme like this:
"C:\Programme\Mozilla Thunderbird\thunderbird.exe" -compose
"to='Edi@de,',attachment='file://d:/cadis/MyMobiler.zip'"

Obviously Thunderbird is only picky with attachment-option, though?!



 Comments   
Comment by axeld [ 03/Nov/11 ]

That seems to be the issue, indeed. The attached patch fixes the problem, and lets me open mails with attachments just fine with Thunderbird 7.0.1.

Generated at Thu Dec 08 12:26:54 UTC 2016 using JIRA 6.2.3#6260-sha1:63ef1d6dac3f4f4d7db4c1effd405ba38ccdc558.