[JSON_PROCESSING_SPEC-41] Remove NumberType.LONG and rename NumberType.BigDecimal Created: 11/Dec/12 Updated: 14/Dec/12 Resolved: 14/Dec/12
|Remaining Estimate:||Not Specified|
|Time Spent:||Not Specified|
|Original Estimate:||Not Specified|
NumberType would be less confusing if it just stated the distinction whether a number has a fractional part.
A NumberType of INTEGER would guarantee that calling getBigIntegerValue does not throw an ArithmeticException. The NumberType would be independent of the actual magnitude of the number, thus calling getIntValueExact might still throw an Exception if the number is smaller than Integer.MIN_VALUE of larger than Integer.MAX_VALUE.
The current NumberType BIG_DECIMAL should be renamed to just DECIMAL or REAL (see http://en.wikipedia.org/wiki/Real_number) and would indicate that the number has a fractional part and calling get(Int|Long|BigInteger)ValueExact might throw an ArithmeticException.
The algorithm for distinguishing these two types should be based on whether BigDecimal#scale() is 0.
|Comment by jhorstmann [ 11/Dec/12 ]|
On a Jave ME profile of this JSON API, the methods getBigIntegerValue(Exact) and getBigDecimalValue would be excluded, NumberType should be INTEGER if the number can be exactly represented as a long, which is the largest integral type on such platforms.
|Comment by jitu [ 11/Dec/12 ]|
The current number type is the minimum holding number type. For 1.23e2, it gives INT.
This proposal is primarily removing "minimum holding" number type. So API doesn't provide a way if the integral number fits into int, long, BigInteger, and it becomes an application responsibility.
If applications don't require to know about this minimum holding number type, then I am fine with the proposal. I will see if there any comments internally.
|Comment by keilw [ 12/Dec/12 ]|
>The algorithm for distinguishing these two types should be based on whether >BigDecimal#scale() is 0.
What would it be on ME, as BigDecimal and BigInteger would not be there?
Aside from that, I fully agree with renaming BIG_DECIMAL to something like DECIMAL, REAL or FLOATING, which covers all numbers with decimal value.
And keep INTEGER or rename INT, ideally dropping the LONG.
An alternative could again be the JSON spec which knows
If there are sufficient algorithms to tell FRAC (which is quite similar to FLOATING or DECIMAL) from EXP, this may be closest to JSON design.
|Comment by jitu [ 13/Dec/12 ]|
ME could use a similar algo what scale() is doing to determine if the number has a fractional part or not.
I am thinking of rolling the following:
|Comment by jhorstmann [ 13/Dec/12 ]|
A ME profile would probably store the number in a double, which has no concept similar to BigDecimal#scale(). It could return type INTEGER if getDoubleValue() == Math.floor(getDoubleValue());, but this would return different results than an implementation based on BigDecimal for numbers like "1.0".
The equivalent code with BigDecimal would be:
If we can not decide on the correct semantics, then it would probably be better to remove the NumberType distinction completely or defer it to a future version.
|Comment by jitu [ 13/Dec/12 ]|
Let me commit the proposal in this issue. I don't think we need to define what ME is going to do here now. Anyway, ME needs to define semantics for other methods like equals(), hashCode() etc.
|Comment by jitu [ 14/Dec/12 ]|
Resolving with the proposal in this issue