[PORTLETSPEC3-38] Ajax: Change name "JavaScript Portlet" to ... something less confusing Created: 13/Dec/13  Updated: 22/Jan/16  Resolved: 22/Jan/16

Status: Closed
Project: portletspec3
Component/s: Stateful Ajax Support
Affects Version/s: None
Fix Version/s: None

Type: New Feature Priority: Major
Reporter: msnicklous Assignee: Unassigned
Resolution: Fixed Votes: 0
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified


Reference: Ajax Proposal 2b

The term "JavaScript Portlet" for client-side code is confusing as it sounds as though the portlet would actually be running in JavaScript on the client, which is not the case.

Instead, the "JavaScript Portlet" is a piece of JavaScript code provided by the portlet for handling the portlet UI.

I understand the conflict, but don't have a good naming proposal right offhand, so please provide better suggestions.

Comment by kito75 [ 14/Jan/14 ]

How about JavaScript Portlet UI?

Comment by msnicklous [ 22/Jan/16 ]

done. We went with "Portlet Client" to designate the JavaScript code provided by the portlet for execution on the client and "Portlet Hub" to designate the client-side JavaScript code representing the portal.

Generated at Wed Oct 26 06:21:08 UTC 2016 using JIRA 6.2.3#6260-sha1:63ef1d6dac3f4f4d7db4c1effd405ba38ccdc558.