[SAILFIN-1863] [regression] could not access application after upgrade Created: 20/Jul/09  Updated: 30/Jul/09  Resolved: 30/Jul/09

Status: Resolved
Project: sailfin
Component/s: Tools
Affects Version/s: 2.0
Fix Version/s: milestone 1

Type: Bug Priority: Critical
Reporter: 1xpert Assignee: Satish Kumar
Resolution: Fixed Votes: 0
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified
Environment:

Operating System: All
Platform: Sun


Attachments: Text File broker_instance1.txt     Text File instance.log     Text File instance1.log     Text File nodeagent.log    
Issuezilla Id: 1,863

 Description   

Sidebyside upgrade for cluster support between sailfin 1.0 to sailfin 2.0 b23

After upgrade, could not access application onlinebank on machine 1 at
http://<machine 1>:38080. On machine 2, application works fine.



 Comments   
Comment by 1xpert [ 20/Jul/09 ]

Created an attachment (id=1044)
instance log

Comment by 1xpert [ 20/Jul/09 ]

Created an attachment (id=1045)
nodeagent log

Comment by naman_mehta [ 21/Jul/09 ]

Created an attachment (id=1048)
Adding instance log for JMS error.

Comment by naman_mehta [ 21/Jul/09 ]

This is failing due to JMS is not starting up after upgrade from 1.5 to 2.0.
Assigning this to satish for further investigation.

Comment by naman_mehta [ 21/Jul/09 ]

Assigned it to wrong userid. Now Assigning to Satish (sats).

Comment by Nigel Deakin [ 22/Jul/09 ]

The local broker is not starting for an unknown reason. before we explore
further I'd like to check whether you're hitting an issue caused by the wrong
version of Microsoft's C++ libraries being installed on your Windows machine.

The quick way to test this is whether you are able to use the
imq\bin\imqbrokerd.exe to start a standalone broker or not. If your C++
libraries are incorrect this will fail. (Simply make sure there is no broker or
Glassfish instance running on your machine and then execute that program).

Please see Glassfish issue 8711 for more information.
(https://glassfish.dev.java.net/issues/show_bug.cgi?id=8771)

Comment by Nigel Deakin [ 22/Jul/09 ]

Mrs/Miss/Mr 1xpert: My previous response related to Naman's attenmpt to
reproduce the issue. As for your issue, can you please supply broker logs for
the local broker used by instance1? This didn't seem to start for some reason.

Comment by 1xpert [ 22/Jul/09 ]

Created an attachment (id=1054)
imq broker log on machine1

Comment by Nigel Deakin [ 22/Jul/09 ]

Thanks. I'm trying to see if there's anything in the broker log corresponding to
the point in the Glassfish instance that started the broker. This is the part of
the Glassfish server log I was interested in:

glassfish-comms-server1.5|javax.resourceadapter.mqjmsra.lifecycle|_ThreadID=11;_ThreadName=main;|MQJMSRA_LB1101:
Looking for Broker Running at:localhost:37676|#]

[#|2009-07-20T13:23:45.903-0700|WARNING|sun-glassfish-comms-server1.5|javax.jms|_ThreadID=11;_ThreadName=main;_RequestID=6a4a8948-c3eb-46a0-998f-5082b1053123;|[C4003]:
Error occurred on connection creation [localhost:37676]. - cause:
java.net.ConnectException: Connection refused|#]

[#|2009-07-20T13:23:46.981-0700|WARNING|sun-glassfish-comms-server1.5|javax.jms|_ThreadID=11;_ThreadName=main;_RequestID=6a4a8948-c3eb-46a0-998f-5082b1053123;|[C4003]:
Error occurred on connection creation [localhost:37676]. - cause:
java.net.ConnectException: Connection refused|#]

[#|2009-07-20T13:23:47.991-0700|WARNING|sun-glassfish-comms-server1.5|javax.jms|_ThreadID=11;_ThreadName=main;_RequestID=6a4a8948-c3eb-46a0-998f-5082b1053123;|[C4003]:
Error occurred on connection creation [localhost:37676]. - cause:
java.net.ConnectException: Connection refused|#]

[#|2009-07-20T13:23:50.468-0700|INFO|sun-glassfish-comms-server1.5|javax.resourceadapter.mqjmsra.lifecycle|_ThreadID=11;_ThreadName=main;|MQJMSRA_RA1101:
SJSMQ JMSRA Started:LOCAL|#]

The MQ broker log you supplied began at 13:36:16, which was later. This suggests
the broker never even started.

I notice you started the broker several times subsequent to that. The first two
times it seemed to fail; the third time it ran for a few seconds and then shut
down. Can you say what you were doing to trigger this? Did you start the
Glassfish instance again? If so, can you supply its server log?

Comment by naman_mehta [ 27/Jul/09 ]

hi 1xpert,

I tested side by side upgrade on Linux machine. I couldn't able to reproduce
this error.

Have you tried same on Linux?
On which OS are you getting this error? Is it spar/x86 machine?

Naman.

Comment by 1xpert [ 30/Jul/09 ]

Tried starting nodeagent with syncinstances option on machine1 and was able to
access application after upgrade.

Comment by 1xpert [ 30/Jul/09 ]

reassign

Comment by naman_mehta [ 30/Jul/09 ]

Closing this issue as it works with syncinstances=true option on both machines.

Generated at Mon May 04 15:03:40 UTC 2015 using JIRA 6.2.3#6260-sha1:63ef1d6dac3f4f4d7db4c1effd405ba38ccdc558.