[YGGDRASIL-15] Subversion repository Checkout fails on Mac Created: 01/Jul/09  Updated: 01/Jul/09  Resolved: 01/Jul/09

Status: Resolved
Project: yggdrasil
Component/s: SensorNetwork
Affects Version/s: current
Fix Version/s: milestone 1

Type: Bug Priority: Blocker
Reporter: giovannirimon Assignee: vipul_gupta
Resolution: Fixed Votes: 0
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified
Environment:

Operating System: All
Platform: Macintosh


Issuezilla Id: 15

 Description   

When I tried to checkout the Sensor Network svn repository using NetBeans6.7 I get the following error:

In directory '/Users/ga235815/NetBeansProjects/Sensor.Network/SensorNetwork-web/trunk/SNMain-
new/web/images'
Can't move source to dest
Can't move '/Users/ga235815/NetBeansProjects/Sensor.Network/SensorNetwork-web/trunk/SNMain-
new/web/images/.svn/tmp/prop-base/eSpot-shadow.png.svn-base' to
'/Users/ga235815/NetBeansProjects/Sensor.Network/SensorNetwork-web/trunk/SNMain-
new/web/images/.svn/prop-base/eSpot-shadow.png.svn-base': No such file or directory

however, when I try to cleanup I still get another error regarding this file: "eSPOT-shadow.png" saying
it is not under version control.

svn: In directory 'SensorNetwork-web/trunk/SNMain-new/web/images'
svn: Error processing command 'modify-wcprop' in 'SensorNetwork-web/trunk/SNMain-
new/web/images'
svn: 'SensorNetwork-web/trunk/SNMain-new/web/images/eSPOT-shadow.png' is not under version
control

One thing worths mentioning here is that trying this over Linux "Fedora 11" did not reproduce the
same errors. It worked just fine.

-Giovani



 Comments   
Comment by arshan [ 01/Jul/09 ]

changed to P1 as its holding up the whole team

Comment by vipul_gupta [ 01/Jul/09 ]

I need someone with better SVN expertise to help here. Even though SNMain-new is no longer needed (it
is superceded by SNMainv2), I'm unable to delete it. For now, use the following workaround:

% cd <path-to-SensorNetwork-web>/trunk
% svn co SNMainv2

vipul

Comment by vipul_gupta [ 01/Jul/09 ]

Ok. I have finally managed to remove SNMain-new and I don't see the problem any more when I checkout
SensorNetwork on my MAC.

Generated at Sun Apr 30 18:51:30 UTC 2017 using JIRA 6.2.3#6260-sha1:63ef1d6dac3f4f4d7db4c1effd405ba38ccdc558.