[JSR348-156] platform comaptibility requirements for new specs unclear Created: 29/Jan/13  Updated: 29/Jan/13

Status: Open
Project: jsr348
Component/s: Process Doc
Affects Version/s: None
Fix Version/s: None

Type: Bug Priority: Minor
Reporter: Bill Shannon Assignee: Unassigned
Resolution: Unresolved Votes: 0
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified


 Description   

The process document says:

2.1.3 PROFILES AND API SPECIFICATIONS TARGET CURRENT PLATFORM EDITIONS

All new or revised Specifications must be compatible with the most recent versions
of the targeted Platform Edition Specifications.

It's not clear what this requirement really means. Our current interpretation is
that the RI and TCK for the Specification must run on the most recent version of the
targeted platform. We do not interpret this to mean that the Specification must
use any particular feature of the most recent platform version. Use or non-use of
platform features is a decision for the expert group for the Specification. For
example, a Specification may be designed to be implementable on older versions of
the targeted platform and thus choose not to use features of the most recent platform
version.






Generated at Wed Jun 03 06:36:26 UTC 2015 using JIRA 6.2.3#6260-sha1:63ef1d6dac3f4f4d7db4c1effd405ba38ccdc558.