[PORTLETSPEC3-67] Add Multipart Support Created: 29/Jan/16 Updated: 30/May/16
|Remaining Estimate:||Not Specified|
|Time Spent:||Not Specified|
|Original Estimate:||Not Specified|
See PORTLETSPEC3-59 for method descriptions.
Multipart requests should be supported to allow file uploads, etc.
Add the following methods:
1) Add a Multipart annotation that can only be used within an @PortletConfiguration annotation
2) Allow the same info to be specified through the portlet deployment descriptor
The alternative to adding a new annotation would be to just require use of
|Comment by Neil Griffin [ 29/Feb/16 ]|
+1 for this issue in general, but here are some additional items...
1) Adding a multipart-config element will require a change to the portlet-app_3_0.xsd schema document.
3) Rather than add another annotation like @Multipart, I think it might be simpler to add attributes like location, max-file-size, etc. to the @PortletConfiguration annotation.
|Comment by Neil Griffin [ 02/Mar/16 ]|
During the EG call on 29 Feb 2016 I think we decided to pursue #1, #2, and #3 from my comments above and that we would not create a new @Multipart annotation.
|Comment by msnicklous [ 20/May/16 ]|
Please see the API documentation describing these methods here.
A reference implementation snapshot implementing the methods is located here.
A portlet specification snapshot describing the new methods is available here.
|Comment by Neil Griffin [ 27/May/16 ]|
@msnicklous: I'm temporarily re-opening this issue in order to ask a question:
As discussed in the comment above, during an EG call we decided against the @Multipart annotation, but I see that the latest version of the Portlet 3.0 JavaDoc includes the annotation. Should it have been removed? Thanks, Neil
|Comment by msnicklous [ 30/May/16 ]|
The portlet 3.0 javadoc does contain an @Multipart annotation, but it has @Target(value=ANNOTATION_TYPE) so it can only be used within another annotation, and not stand-alone. In particular, it is used in the @PortletConfiguration annotation. I thought of going with @MultipartPortlet instead, but to me it just seemed to make the the configuration more verbose without really adding clarity.
If there are other opinions, or a different idea for a short name, we can discuss.