Skip to main content

Re-adding JSP Java compiler support for JDT and Ant

  • From: Eirik Bjørsnøs <eirbjo@...>
  • To: dev <dev@...>
  • Subject: Re-adding JSP Java compiler support for JDT and Ant
  • Date: Wed, 19 Mar 2014 13:32:35 +0100

Hi,

I was bitten by JSP-38 [1] today when upgrading to the latest version of 
Jetty:

https://java.net/jira/browse/JSP-38

For similar reasons to what Jan describes, we can't use the
Jsr199JavaCompiler, since our embedding does not allow us to express
our class path as a list of files.

So we're forced to use the JDTJavaCompiler, which for some
non-intuitive reason is excluded from compilation in Glassfish JSP.

If this was done to remove dependencies on JDT / Ant, why not just
mark those dependencies as <optional>true</optional>?

I've added a patch that does exactly this in my comment on JSP-38.
I've tested it with the latest Jetty and found it to work as expected.

Could someone shed some light as to why JDT / Ant support was removed?

Any reason not to add it back?

Eirik.


Re-adding JSP Java compiler support for JDT and Ant

Eirik Bjørsnøs 03/19/2014
 
 
Close
loading
Please Confirm
Close