Skip to main content

Source code revision

svn

summary: Issue 15778: Endorsed bundles don't get updated properly when updating 3.0.x installation with 3.1 packages. This happens because in 3.0.x, we used to install endorsed bundles using location such as
revision: 44816
author: Sahoo
date: 2011-02-02 01:19:01 UTC (6 years)
message: Issue 15778: Endorsed bundles don't get updated properly when updating 3.0.x installation with 3.1 packages.
This happens because in 3.0.x, we used to install endorsed bundles using location such as
file:/space/glassfishv3/glassfish/modules/endorsed/javax.annotation.jar.
Because of a typo in felix and equinox config file, we now install them as
file:/space/glassfishv3/glassfish//modules/endorsed/javax.annotation.jar.
This cause them to be treated differently.

We are now making the location same as what it used to be.

See JIRA for change control process.

Change Path Actions
M branches/3.1/osgi-platforms/equinox/src/main/resources/glassfish/osgi/equinox/configuration/config.ini
M branches/3.1/osgi-platforms/felix/src/main/resources/glassfish/osgi/felix/conf/config.properties
 
 
Close
loading
Please Confirm
Close