Skip to main content

NullPointerException while building

  2 posts   Feedicon  
Replies: 1 - Last Post: August 03, 2011 23:39
by: Winston Prakash
showing 1 - 2 of 2
Posted: July 27, 2011 10:19 by arka.sharma
Hi All,

Please give me some idea regarding following.I have one project which is successfully built using "mvn clean install".But while building from hudosn it is throwing following exceptions

ERROR: Processing failed due to a bug in the code. Please report this to dev@hudson.java.net
java.lang.NullPointerException
at hudson.FilePath.isAbsolute(FilePath.java:225)
at hudson.FilePath.<init>(FilePath.java:212)
at hudson.FilePath.child(FilePath.java:896)
at hudson.maven.MavenModuleSetBuild$RunnerImpl.doRun(MavenModuleSetBuild.java:554)
at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:429)
at hudson.model.Run.run(Run.java:1363)
at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:405)
at hudson.model.ResourceController.execute(ResourceController.java:88)
at hudson.model.Executor.run(Executor.java:145)
project=hudson.maven.MavenModuleSet@445f5a[Mach]
project.getModules()=[hudson.maven.MavenModule@108b647[Mach/mach:captive-portal][Mach/mach:captive-portal][relativePath:null], hudson.maven.MavenModule@52c8c7[Mach/mach:dre-ear][Mach/mach:dre-ear][relativePath:null], hudson.maven.MavenModule@c51aac[Mach/mach:mach-portal-buisinesslogic][Mach/mach:mach-portal-buisinesslogic][relativePath:null], hudson.maven.MavenModule@1244cf2[Mach/mach:sdp-root][Mach/mach:sdp-root][relativePath:C:\maven_build\mach], hudson.maven.MavenModule@37be19[Mach/mach:sdp-statemachine][Mach/mach:sdp-statemachine][relativePath:null]]
project.getRootModule()=hudson.maven.MavenModule@1244cf2[Mach/mach:sdp-root][Mach/mach:sdp-root][relativePath:C:\maven_build\mach]
FATAL: null
java.lang.NullPointerException
at hudson.FilePath.isAbsolute(FilePath.java:225)
at hudson.FilePath.<init>(FilePath.java:212)
at hudson.FilePath.child(FilePath.java:896)
at hudson.maven.MavenModuleSetBuild$RunnerImpl.doRun(MavenModuleSetBuild.java:554)
at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:429)
at hudson.model.Run.run(Run.java:1363)
at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:405)
at hudson.model.ResourceController.execute(ResourceController.java:88)
at hudson.model.Executor.run(Executor.java:145)

and the build fails.I'm using hudson 2.0.1 with JBoss 5.1.

Thanks,
Arka
Posted: August 03, 2011 23:39 by Winston Prakash
What version of Hudson are you using. Did you try with latest version (2.1.0), which has Maven3 integrated.
Replies: 1 - Last Post: August 03, 2011 23:39
by: Winston Prakash
 
 
Close
loading
Please Confirm
Close