Skip to main content

[Hudson-Dev] Re: Issue with Auto Deployment into JBoss server

  • From: Winston Prakash <winston.prakash@...>
  • To: lalitha kumari <lchitrala@...>
  • Cc: dev@..., DUNCAN MILLS <duncan.mills@...>
  • Subject: [Hudson-Dev] Re: Issue with Auto Deployment into JBoss server
  • Date: Fri, 30 Sep 2011 07:26:00 -0700

Lalitha,

It appears very few people affected by an issue when they upgraded to 2.1.1 from certain version of older Hudson. The issue is related to some missing value in the older version of Hudson Job configuration. This is fixed and the fix will be available in 2.1.2 which will be released in a day or two.

We are not sure about the version of Hudson which has the missing value. What version Hudson you were before upgrading to Hudson 2.1.1?

- Winston

On 9/30/11 12:46 AM, lalitha kumari wrote:
Hi Winston,
 
I have downloaded Hudson 2.1.1 war and deployed it in JBoss server and created a job and gave a build. But i am getting the below error.
 
[ERROR] FATAL ERROR
[INFO] ------------------------------------------------------------------------
[INFO] null
[INFO] ------------------------------------------------------------------------
[INFO] Trace
java.lang.NullPointerException
at hudson.model.RunMap$2.compare(RunMap.java:188)
at hudson.model.RunMap$2.compare(RunMap.java:184)
at java.util.TreeMap.compare(TreeMap.java:1173)
at java.util.TreeMap$NavigableSubMap.<init>(TreeMap.java:1245)
at java.util.TreeMap$AscendingSubMap.<init>(TreeMap.java:1677)
at java.util.TreeMap.headMap(TreeMap.java:876)
at java.util.TreeMap.headMap(TreeMap.java:914)
at hudson.model.RunMap.headMap(RunMap.java:160)
at hudson.model.RunMap.headMap(RunMap.java:51)
at java.util.Collections$UnmodifiableSortedMap.headMap(Collections.java:1483)
at hudson.model.Job.getNearestBuild(Job.java:612)
 
What could be the reason. Please let me know if it is a problem with the new version of Hudson.
 
Regards,
Lalitha. 
 
 
 
Hi

On Tue, Sep 27, 2011 at 7:03 PM, DUNCAN MILLS <duncan.mills@...> wrote:
I've added a quick note to the JBoss Wiki[1] page with this info.

Lalitha, as you install can you help the project out by verifying the contents of that page and making any corrections that you need for version 6. That would be a great help.

[1] http://wiki.eclipse.org/Hudson-ci/Containers/JBoss

Duncan


On 9/27/2011 2:02 AM, Winston Prakash wrote:
I have released Deploy Plugin 1.7 that supports deployment to JBoss 6.0

- Winston

On 8/11/11 4:04 AM, lalitha kumari wrote:
Hi,
I am using Hudson for Continuous Integration. I am also using the Jboss 6.0.0 as the application server.
I want to do auto deployment into the JBoss server once the build is done in Hudson.
I have gone through the Deploy plug which is used for auto deployment, but that is not having support for JBoss 6.0
Can i know if there is any other way that i can do the auto deployment into JBoss6.0 after the continuous build through Hudson.
If any, please provide me the URL details.
Awaiting for your reply.
Thanks in advance.
Regards,
Lalitha.





[Hudson-Dev] Re: Issue with Auto Deployment into JBoss server

Winston Prakash 09/27/2011

[Hudson-Dev] Re: Issue with Auto Deployment into JBoss server

DUNCAN MILLS 09/27/2011

[Hudson-Dev] Re: Issue with Auto Deployment into JBoss server

lalitha kumari 09/30/2011

[Hudson-Dev] Re: Issue with Auto Deployment into JBoss server

Winston Prakash 09/30/2011
 
 
Close
loading
Please Confirm
Close