Skip to main content

[Hudson-Users] Odd issue with the CLI interface

  • From: Henrik Lynggaard Hansen <henrik@...>
  • To: Hudson Dev <dev@...>, Hudson Users <users@...>
  • Subject: [Hudson-Users] Odd issue with the CLI interface
  • Date: Mon, 30 May 2011 13:02:32 +0200

Hi

When I look at the CLI interface for hudson, it looks like there is
something very basic missing. It is apparently not possible to update
a job without loosing the history. There is a create-job and
delete-job but no update-job. To me that is so basic that I suspect I
have missed something fundamental.

The reason this is a pain point for us is because the workaround is
really slow, what we do is

* Set hudson in shutdown mode so it doesn't build
* On the server move the job history to a backup folder
* delete and recreate the job
* copy the job history back
* trigger the reload configuration from history. This is needed to
have hudson recognize the build history.

The last step takes 20-30 minutes on our hudson installation, which
basicly means our CI server will have a outage of 30-40 minutes.

Am I missing some basic functionality ? ,
Or is our workflow completely wrong, possibly a different way to
administer jobs ?
Or is it just a old lack of functionality in Hudson ?

Best regards
Henrik


[Hudson-Users] Odd issue with the CLI interface

Henrik Lynggaard Hansen 05/30/2011

[Hudson-Users] Re: [Hudson-Dev] Odd issue with the CLI interface

Winston Prakash 05/31/2011
 
 
Close
loading
Please Confirm
Close