Skip to main content

Source code Changes To

pkg-gate / src / modules / lint / pkglint_action.py

From revision 2955 to 2958:

diff -r 796cde775790 -r 868e07939116 src/modules/lint/pkglint_action.py
--- a/src/modules/lint/pkglint_action.py	Fri Sep 27 10:19:27 2013 +1200
+++ b/src/modules/lint/pkglint_action.py	Fri Sep 27 11:38:34 2013 -0700
@@ -1294,8 +1294,7 @@
                         name = declared_fmri.get_name()
                 except pkg.fmri.IllegalFmri:
                         try:
-                                declared_fmri = pkg.fmri.PkgFmri(dep_fmri,
-                                    build_release="5.11")
+                                declared_fmri = pkg.fmri.PkgFmri(dep_fmri)
                                 name = declared_fmri.get_name()
                         except:
                                 # A very broken fmri value - we'll give up now.
@@ -1386,8 +1385,7 @@
                                 # we also need to just verify that the fmri
                                 # isn't just missing a build_release value
                                 try:
-                                        pfmri = pkg.fmri.PkgFmri(fmri,
-                                            build_release="5.11")
+                                        pfmri = pkg.fmri.PkgFmri(fmri)
                                 except pkg.fmri.IllegalFmri:
                                         engine.error("invalid FMRI in action "
                                             "%(action)s in %(pkg)s" %
@@ -1496,7 +1494,7 @@
                         return
 
                 fmri = action.attrs["fmri"]
-                pfmri = pkg.fmri.PkgFmri(fmri, build_release="5.11")
+                pfmri = pkg.fmri.PkgFmri(fmri)
                 if not pfmri.version:
                         engine.error(
                             _("'incorporate' depend action on %(fmri)s in "

 
 
Close
loading
Please Confirm
Close