Skip to main content

SEVERE: invalid Java API configuration

  1 post   Feedicon  
Replies: 0 - Last Post: May 31, 2012 13:30
by: Tangled
showing 1 - 1 of 1
Posted: May 31, 2012 13:30 by Tangled
Hello!
I downloaded and installed hotfolders. It runs, when i enable web-services ("ws" option). But fails, when i use Java API.
Here is my log:

C:\>java -Xms128m -Xmx512m -Djava.util.logging.config.file=C:\hotfolders\hotfolders-logging.properties -cp C:\hotfolders\hotfolders.jar;C:\hotfolders\api\lib\irm-api.jar oracle.irm.hotfolde
rs.HotFoldersApp C:\hotfolders\hot.properties
31.05.2012 16:54:35 oracle.irm.hotfolders.HotFolders <init>
INFO: Oracle IRM Hot Folders - version 4.0.0
31.05.2012 16:54:36 oracle.irm.hotfolders.HotFolders <init>
INFO: Java home: C:\Program Files\Java\jre6
31.05.2012 16:54:36 oracle.irm.hotfolders.HotFolders <init>
INFO: CLASSPATH: C:\hotfolders\hotfolders.jar;C:\hotfo
lders\api\lib\irm-api.jar
31.05.2012 16:54:36 oracle.irm.hotfolders.HotFolders <init>
INFO: os.name
31.05.2012 16:54:36 oracle.irm.hotfolders.HotFolders <init>
INFO: os.arch
31.05.2012 16:54:36 oracle.irm.hotfolders.HotFolders <init>
INFO: os.version
31.05.2012 16:54:36 oracle.irm.hotfolders.HotFolders <init>
INFO: logger properties: C:\hotfolders\hotfolders-logging.propertie
s
31.05.2012 16:54:36 oracle.irm.hotfolders.HotFolders <init>
INFO: default locale: ru_RU
31.05.2012 16:54:36 oracle.irm.hotfolders.HotFolders <init>
INFO: logger resource bundle: hotfoldersbundle
31.05.2012 16:54:36 oracle.irm.hotfolders.HotFolders <init>
INFO: if wrong language or poor translation - see documentation for how to add s
upport for your locale
31.05.2012 16:54:36 oracle.irm.hotfolders.HotFolders <init>
SEVERE: invalid Java API configuration
31.05.2012 16:54:36 oracle.irm.hotfolders.HotFolders processFolders
INFO: 2 folders defined
Exception in thread "main" java.lang.NullPointerException
at oracle.irm.hotfolders.HotFolders.processFolder(HotFolders.java:627)
at oracle.irm.hotfolders.HotFolders.processFolders(HotFolders.java:815)
at oracle.irm.hotfolders.HotFoldersApp.main(HotFoldersApp.java:30)

I use java 1.6.0_31.
Why is it happen? How i can solve this problem?
Replies: 0 - Last Post: May 31, 2012 13:30
by: Tangled
 
 
Close
loading
Please Confirm
Close