Skip to main content

[JSR-354] Re: Getting a name method into CurrencyUnit

  • From: Sascha Freitag <dunschtig@...>
  • To: jcurrency_mail@...
  • Subject: [JSR-354] Re: Getting a name method into CurrencyUnit
  • Date: Sat, 20 Apr 2013 20:58:32 +0200

Hi all,

yes I think also it's good to have the i18n aspects separate. And as also mentioned, I think it would be good to have the name in English (for languages with more advanced character sets e.g. Chinese this will be even a transcript) as also provided by ISO. But I would not call it something with ISO in the name, since this would not make much sense for non ISO currencies which we like to support too.

Regards Sascha
On 19.04.2013 00:33, Werner Keil wrote:

Sounds good.
Has the legal team been able to have a final look at the license?

Am 19.04.2013 00:03 schrieb "Anatole Tresch" <atsticks@...>:
Renaming LocalizableItem to FormattableItem seems for me a good idea, matches better with the format functions in the same package...
So summarizing:
  • we rename LocalizableItem to FormattableItem
  • we introduce Localizable within the core package, with a single method getDisplayName(Locale).
Anatole


2013/4/18 Werner Keil <werner.keil@...>
All,

Obviously toString() works on every interface, so I don't really see why 310 TemporalUnit has that redundant declaration?

As of now, java.util.Currency simply returns the ISO code, and MoneyCurrency simply has no place where a name or description information could be stored, so it's lost. While anything you want to display including a human readable form could be done via toString() so it wouldn't be too vital to declare extra methods, but storing it, and adding further options to the static Builder could be beneficial.
Unless we wanna have those properties back?

The idea of a Localizable interface as mentioned seems interesting.
What we might want to do is rename LocalizableItem to e.g. FormattableItem in such case, or e.g. call the other interface Displayable.
A minor overlap with a MIDP abstract base UI class seems like we can safely ignore. Nobody can avoid a class or two with the same name in different APIs. Just take Java 8, its primary UI framework JavaFX and java.time both got a class named Duration with exactly the same purpose

Regards,
Werner



--
Anatole Tresch
Java Lead Engineer, JSR Spec Lead
Glärnischweg 10
CH - 8620 Wetzikon

Switzerland, Europe Zurich, GMT+1
Twitter:  @atsticks
Google: atsticks
Phone   +41-44 334 40 87
Mobile  +41-76 344 62 79


-- 

Sascha Freitag v/o Dunschtig


[JSR-354] Re: Getting a name method into CurrencyUnit

(continued)

[JSR-354] Re: Getting a name method into CurrencyUnit

Werner Keil 04/17/2013

[JSR-354] Re: Getting a name method into CurrencyUnit

Werner Keil 04/18/2013

[JSR-354] Re: Getting a name method into CurrencyUnit

Werner Keil 04/18/2013

[JSR-354] Re: Getting a name method into CurrencyUnit

Simon Martinelli 04/18/2013

[JSR-354] Re: Getting a name method into CurrencyUnit

Werner Keil 04/18/2013

[JSR-354] Re: Getting a name method into CurrencyUnit

Simon Martinelli 04/18/2013

[JSR-354] Re: Getting a name method into CurrencyUnit

Werner Keil 04/18/2013

[JSR-354] Re: Getting a name method into CurrencyUnit

Werner Keil 04/18/2013

[JSR-354] Re: Getting a name method into CurrencyUnit

Anatole Tresch 04/18/2013

[JSR-354] Re: Getting a name method into CurrencyUnit

Werner Keil 04/18/2013

[JSR-354] Re: Getting a name method into CurrencyUnit

Sascha Freitag 04/20/2013

[JSR-354] Re: Getting a name method into CurrencyUnit

Chris Pheby 04/18/2013

[JSR-354] Re: Getting a name method into CurrencyUnit

Werner Keil 04/18/2013

[JSR-354] Re: Getting a name method into CurrencyUnit

Tresch Anatole (KFSC 225) 04/18/2013

[JSR-354] Re: Getting a name method into CurrencyUnit

Werner Keil 04/18/2013

[JSR-354] Re: Getting a name method into CurrencyUnit

Simon Martinelli 04/17/2013

[JSR-354] Re: Getting a name method into CurrencyUnit

Werner Keil 04/17/2013
 
 
Close
loading
Please Confirm
Close