Skip to main content

[JSR-354] Ballot - please reply soon!

  • From: Anatole Tresch <atsticks@...>
  • To: Jsr 354 JavaMoney Public Mailinglist <jcurrency_mail@...>
  • Subject: [JSR-354] Ballot - please reply soon!
  • Date: Mon, 8 Apr 2013 23:35:18 +0200

Dear All

may I ask for a short ballot on the most important points I currently would like have a more common sense about???

Core (answer with Y or N, my opinions are inline):
1) Remove LocalizableCurrencyUnit, LocalizableAmount?  Y
both interfaces are defined but currently not used. Additionally the formatting module defines a LocalizableItem, which basically models the same.
 
2) Use 310 names for methods on MonetaryAmount: N (perhaps rename ulp...)
JSR 310 names like plus, minus, multipliedBy, scaled, negated (paste tense in general),
 
3) Should we replace the methods asType, intValue, doubleValue etc. on MonetaryAmount, with BigDecimal getBigDecimal()? Y

4) Should we support Number as input type on algorithmic operation on MonetaryAmount also? N
e.g. (on Money) Money add(MonetaryAmount) also is defined as Money add(Number).
 
5) Should we rename the Rounding interface to MonetaryAdjuster? N
MoneyAdjuster is more bread. MoneyRounding (class) can then implement MoneyAdjuster (interface).
 
6) Should we CHange Rounding:  public MonetaryAmount round(MOnetaryAmount amount); would be changed to public <T extends MonetaryAmount> T round(T amount);: Y
With instance of Money value type this would enable to write the following code:
Money m = rounding.round(Money.of("CHF", 1234.34));
 
7) Should we drop the extensions stuff and introduce corresponding singletons (they still can reuse the ComponentLoader for loading the implementations): Y

8) Should we introduce an additional RoundingType, to distinguish the usage such as cash, online, card? N

9) Should Region be modelled as extendable class instead of an interface? Y

  • Please fill in this form and send it back to me as soon as possible.
  • Please only answer with Y or N, or leave the answer open, if you really do not have an opinion. I want to avoid a broader discussion as of now (which must not mean, that I will start one, if needed, but I think a ballot is enough here, since the topics are rather specific.

Thank very much, for your quick answers!

Regards,


--
Anatole Tresch
Java Lead Engineer, JSR Spec Lead
Glärnischweg 10
CH - 8620 Wetzikon

Switzerland, Europe Zurich, GMT+1
Twitter:  @atsticks
Google: atsticks
Phone   +41-44 334 40 87
Mobile  +41-76 344 62 79


[JSR-354] Ballot - please reply soon!

Anatole Tresch 04/08/2013

[JSR-354] Re: Ballot - please reply soon!

Werner Keil 04/08/2013

[JSR-354] Re: Ballot - please reply soon!

Tresch Anatole (KFSC 225) 04/09/2013

[JSR-354] Re: Ballot - please reply soon!

Sascha Freitag 04/16/2013

[JSR-354] Re: Ballot - please reply soon!

Stephen Colebourne 04/09/2013

[JSR-354] Re: Ballot - please reply soon!

Werner Keil 04/09/2013

[JSR-354] Re: Ballot - please reply soon!

Werner Keil 04/09/2013

[JSR-354] Re: Ballot - please reply soon!

Tresch Anatole (KFSC 225) 04/09/2013

[JSR-354] Re: Ballot - please reply soon!

Werner Keil 04/09/2013

[JSR-354] Re: Ballot - please reply soon!

Tresch Anatole (KFSC 225) 04/09/2013

[JSR-354] Re: Ballot - please reply soon!

Werner Keil 04/09/2013
 
 
Close
loading
Please Confirm
Close