[JSR-354] Re: Ballot - please reply soon!
- From: Stephen Colebourne <scolebourne@...>
- To: jcurrency_mail@...
- Subject: [JSR-354] Re: Ballot - please reply soon!
- Date: Tue, 9 Apr 2013 13:22:38 +0100
On 8 April 2013 22:35, Anatole Tresch <atsticks@...> wrote:
> Core (answer with Y or N, my opinions are inline):
> 1) Remove LocalizableCurrencyUnit, LocalizableAmount?
> 2) Use 310 names for methods on MonetaryAmount:
> 3) Should we replace the methods asType, intValue, doubleValue etc. on
> MonetaryAmount, with BigDecimal getBigDecimal()?
In the context of what the interface is currently trying to be,
getAmountAsBigDecimal() is better. (I prefer a different kind of
> 4) Should we support Number as input type on algorithmic operation on
> MonetaryAmount also?
Its entirely unsuited to that task, as you can't extract data from it reliably
> 5) Should we rename the Rounding interface to MonetaryAdjuster?
I was proposing Rouding is a special case of adjustment, so such a
class would still exist.
> 6) Should we CHange Rounding: public MonetaryAmount round(MOnetaryAmount
> amount); would be changed to public <T extends MonetaryAmount> T round(T
> 8) Should we introduce an additional RoundingType, to distinguish the usage
> such as cash, online, card?