Skip to main content

[jsr362-observers:] [jsr362-experts:] Maven settings

  • From: Martin Scott Nicklous < >
  • To:
  • Subject: [jsr362-observers:] [jsr362-experts:] Maven settings
  • Date: Sat, 10 Aug 2013 10:23:04 +0200
  • List-id: <jsr362-experts.portletspec3.java.net>


After some discussion, I propose we use the following settings in the maven
pom for portletspec3 in order to comply with the proposed maven versioning
rules located here:

https://wikis.oracle.com/display/GlassFish/Maven+Versioning+Rules

=====
  <groupId>javax.portlet</groupId>
  <artifactId>javax.portlet-api</artifactId>
  <version>3.0-SNAPSHOT</version>
  <name>Java Portlet Specification V3.0</name>
  <description>
    The Java Portlet API version 3.0 developed by the Java
    Community Process JSR-362 Expert Group.
  </description>
=====

In particular,  I think we should use the groupId "javax.portlet".

Would anything speak against doing so?

regards,
Scott



[jsr362-observers:] [jsr362-experts:] Maven settings

Martin Scott Nicklous 08/10/2013

[jsr362-observers:] [jsr362-experts:] Re: Maven settings

Neil Griffin 08/10/2013

[jsr362-observers:] [jsr362-experts:] Re: Maven settings

Werner Keil 08/10/2013

[jsr362-observers:] [jsr362-experts:] Re: Maven settings

Neil Griffin 08/10/2013

[jsr362-observers:] [jsr362-experts:] Re: Maven settings

Werner Keil 08/10/2013

[jsr362-observers:] [jsr362-experts:] Re: Maven settings

Martin Scott Nicklous 08/11/2013

[jsr362-observers:] [jsr362-experts:] Re: Maven settings

Werner Keil 08/12/2013

[jsr362-observers:] [jsr362-experts:] Re: Maven settings

Werner Keil 08/12/2013
 
 
Close
loading
Please Confirm
Close